Results 1 to 6 of 6
  1. #1

    Engine wont crank..

    Hi,
    I had ridden my skie the day before.. today,tried to fire it up but it wont even crank over or not even a click sound from the starter relay.. When i put the key in the meter lights up and also i get the double beep sound but when i click the start button nothing happens.. anybody know how to troubleshoot or where to start?


  2. #2
    geowelsh's Avatar
    Join Date
    Apr 2011
    Location
    Knoxville, Tennessee, United States
    Posts
    336
    +1
    1
    Is it flashing KEY on the screen? What year/model ski is it?
    Check grounds, do you hear fuel pump charge when you put the key on?
    Do you have another key? The learners key?

  3. #3
    Quote Originally Posted by geowelsh View Post
    Is it flashing KEY on the screen? What year/model ski is it?
    Check grounds, do you hear fuel pump charge when you put the key on?
    Do you have another key? The learners key?
    No flashing key on the skie.. when i install the key just goes like normal and yes i can hear the fuel pump charge going on when i put the key on the dess post..

    i've tried the learning key too.. still wont turn over..

  4. #4
    Quote Originally Posted by geowelsh View Post
    Is it flashing KEY on the screen? What year/model ski is it?
    Check grounds, do you hear fuel pump charge when you put the key on?
    Do you have another key? The learners key?
    ohh yesss.. 2010 rxpx 255

  5. #5
    geowelsh's Avatar
    Join Date
    Apr 2011
    Location
    Knoxville, Tennessee, United States
    Posts
    336
    +1
    1
    I'd say a bad dess post, check all your fused and grounds, is it still
    Under warranty...

  6. #6
    Have you had problems with your Start/Stop button? Both it and the DESS post on that ski are about equally prone to failure. If you're getting through the security check and hearing the double beeping, my bet is a bad button or corrosion in that plug on the harness. If you're still not working, plug the key in and jump the terminals on the solenoid with a screwdriver to crank the engine. If it runs, try to kill it with the button. If the button kills it, check your starting circuit.

    Go ahead and check the fuse for your starting system for a no brainer that I never remember, too.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 38
    Last Post: 05-10-2009, 08:16 AM
  2. RXT engine wont turn over
    By bairstow in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 06-18-2008, 12:36 AM
  3. HELP! new RXP-X - removed resonator, now 1 beep, wont crank
    By boostaholic in forum 4-Tec Performance
    Replies: 12
    Last Post: 05-30-2008, 09:15 AM
  4. 1999 XL1200 Wont crank
    By wfhaynes in forum Yamaha Open Discussion
    Replies: 4
    Last Post: 10-23-2007, 11:04 AM
  5. 1999 XL1200 Wont crank
    By wfhaynes in forum Yamaha How To & FAQs
    Replies: 1
    Last Post: 10-22-2007, 07:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •