Results 1 to 9 of 9
  1. #1
    B-Lo's Avatar
    Join Date
    Jul 2011
    Location
    Buffalo, NY
    Posts
    244

    Install day for the VXR

    Well the weather has been getting nice so it was time to get the waverunner outta storage and get it going. Story below.

    Last ride wsa 3 days after I installed the riva CAI, waterbox and hull thru. Took it out in an insane storm on lake erie. Within getting 10 feet it started running like shit. No idea why. Rode a bit but couldnt get her above 30. It was so rough out no big deal. Didnt even get to test the mods out. Take it out of the water and sure enough some plastic wrapped around the impeller. Got it out and took it to the dealer for storage for the winter.

    All winter couldnt wait.

    Picked it up at the dealer where I stored it. Well last day I had it out we were jumping 10 footers in lake erie during an insane october storm. Figured water was in the lines maybe. Well the dealer was supposed to check on it as I said it was running rough(they were winterizing it also for me) Well I go to pick it up. Running like shit. Go in and ask what they did. Well they said they drained all fuel out and refilled. I just rolled my eyes and said I would fix it. Get it back to jetpilot's house. Check the plugs 3 look good 1 looked wet and fouled. Grabbed some plugs at autozone. No big deal. Drained all the fuel out and blew it out of the pump and lines. Put fresh gas in bam starts up no problem. So the question was how did I get water in the gas. Sure enough the riva billet gas cap did not have a seal on it. Picked up a seal at the dealer problem solved.

    Now the new mods. Picked up an RD intake grate, RD ride plate, RD R3 reflash, 12/19 skat swirl, tbm pump cone and riva billet drive shaft sleeve. So head over to jetpilots house to get some wrench time in. First up pull it apart. Not so bad for my ski being kept in a marina during the season. Some bolts were tough but no big deal. First mod in the sleeve kit. This was not as easy to install as it looked. Took me about 30 minutes of messing around but it went in and looks nice. Next up the TBM cone. Went on pretty easy. Issues started to arise after that. Cone went on fine. Its twice the size of the RD cone and at least 3 times of the stocker. Nice piece. Now issue I have this is a 500 dollar piece and they give you 1 washer. Only 1. So if you are probably going to have to figure out another way to get things to work. Now time to get the impeller on and lined up. Uhoh spacer only gave us .004 clearence. WTF TBM? Good thing mark has a lathe so we were able to mill the hub of the impeller down. Now the TBM instructions dont even mention how much clearance you need but thanks to GH .04 is recommended. Now after the we milled down the hub we got it together. UHOH again. The shaft doesnt turn smooth all the way around. Had some sticking points. After doing some troubleshooting sure enough the TBM space is out of round as well as being not thick enough. Lathe time again. Now we are all good. Got every thing else installed no issues. Bummer about the spacer and the milling. Not exactly a bolt on mod for most. Thanks to mark for helping without him my shit would be stock. enjoy a crap video of how she sounds now. GoPro vids will probably be taken this weekend.



  2. #2
    DarkCanuck's Avatar
    Join Date
    Nov 2010
    Location
    Canada
    Posts
    315
    +1
    17
    Sounds awesome but what were you waiting for I was in Lake Ontario in April before I sold mine...question now what dealer is this because I am about to be purchasing a 2012 and there is only 2 dealers that I am aware of in our neck of the woods.

    Thanks!

  3. #3
    B-Lo's Avatar
    Join Date
    Jul 2011
    Location
    Buffalo, NY
    Posts
    244
    Weaver.

    I had my wet suit ready but I keep it in a marina and they weren't open till may lol

  4. #4
    B-Lo's Avatar
    Join Date
    Jul 2011
    Location
    Buffalo, NY
    Posts
    244
    Well got her up to speed. Turned in a 71.4, 70.4 and 69.8 on gps yesterday. Still cavitate on holeshot but its not as bad as it used to be. Still need to tweek some stuff. Thinking of going from 12/19 to 14/17 on the prop. Thoughts?

  5. #5
    1200 stx-r's Avatar
    Join Date
    Jul 2007
    Location
    NWCT
    Posts
    2,517
    +1
    200
    Quote Originally Posted by B-Lo View Post
    Well got her up to speed. Turned in a 71.4, 70.4 and 69.8 on gps yesterday. Still cavitate on holeshot but its not as bad as it used to be. Still need to tweek some stuff. Thinking of going from 12/19 to 14/17 on the prop. Thoughts?

    how is the reflash? did you gain anything? i thought reflash was more top end ??? i am confused......

  6. #6
    maxadrenaline's Avatar
    Join Date
    Nov 2007
    Location
    RETIRED !! In Mobile AL or Wherever I Want To Go
    Posts
    1,414
    +1
    137
    Quote Originally Posted by B-Lo View Post
    Well got her up to speed. Turned in a 71.4, 70.4 and 69.8 on gps yesterday. Still cavitate on holeshot but its not as bad as it used to be. Still need to tweek some stuff. Thinking of going from 12/19 to 14/17 on the prop. Thoughts?
    The 14/17 will work a lot better for you if you are still running the TBM cone. I tried 15/17 but went down to a 12/16 to gain some rpms. I have not had a chance to run it yet.

  7. #7
    B-Lo's Avatar
    Join Date
    Jul 2011
    Location
    Buffalo, NY
    Posts
    244
    Thats what I figured. Gonna borrow a tiny tach to see where the rpms are right now.

  8. #8
    B-Lo's Avatar
    Join Date
    Jul 2011
    Location
    Buffalo, NY
    Posts
    244
    Unfortunately all my mods were done at the same time so no way to judge what added what. I have better pull from start to finish now and gained speed and handling.

  9. #9
    1200 stx-r's Avatar
    Join Date
    Jul 2007
    Location
    NWCT
    Posts
    2,517
    +1
    200
    Quote Originally Posted by B-Lo View Post
    Unfortunately all my mods were done at the same time so no way to judge what added what. I have better pull from start to finish now and gained speed and handling.
    No prob. I did all mine before even riding it by reading everything I could and weeding out the BS . Gonna try a couple other things before I go reflash I guess. Thanks Bruce

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Aftermarket Trim for the VXR !
    By oi812 in forum Yamaha PWC Performance (4-stroke)
    Replies: 13
    Last Post: 02-28-2014, 07:48 AM
  2. RIVA stainless steel intake grate for the VXR/VXS is now available
    By Green Hulk in forum Yamaha PWC Performance (4-stroke)
    Replies: 191
    Last Post: 01-18-2014, 04:19 PM
  3. does anyone remember the install steps for the RPM couplers?
    By jpa1300 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 06-11-2012, 06:11 PM
  4. Lots of new parts for the VXR/VXS
    By Green Hulk in forum Yamaha PWC Performance (4-stroke)
    Replies: 1
    Last Post: 03-01-2011, 02:50 PM
  5. Sad day for the Germans.... Horrible Accident
    By beerdart in forum Open Discussion
    Replies: 13
    Last Post: 03-20-2008, 01:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •