Results 1 to 5 of 5

Thread: You guys rock!!

  1. #1
    Ryman's Avatar
    Join Date
    May 2012
    Location
    Shreveport, LA
    Posts
    42

    You guys rock!!

    I gotta say thanks for all of the help up to this point changing out the SC and general maintenance on my RXP-X! Everything you guys have said has been spot on! The wear ring swap out was simple with the freezer and a rubber mallet.

    I do have one more puzzling problem. The pic below shows it. So this is coolant (At least I think, it's a bright green fluid) I followed the coolant reservoir lines down to the ride plate and noticed that there is some hoses that lead there. But how does it flow up threw the screws? It's definitely not dripping. Does the coolant just sit in the ride plate or something? How do I fix this/prevent this from happening thats really a 3 week accumulation and I think it's increased becasuse of the way the reservoir has been sitting with the couling off. do I need to pull the ride plate off and take a look? or just replace those screws?

    Thanks Again

    Ryman
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMAG0120.jpg 
Views:	108 
Size:	63.3 KB 
ID:	272403  


  2. #2
    Gomer Pyle starter99's Avatar
    Join Date
    Sep 2009
    Location
    GA
    Posts
    642
    +1
    54
    looks like ride plate leaking mine done the something seadoo replace mine no charge

  3. #3
    Ryman's Avatar
    Join Date
    May 2012
    Location
    Shreveport, LA
    Posts
    42
    Yeah I used the search tool and found all the info I needed.

    Thanks

  4. #4
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Quote Originally Posted by Ryman View Post
    Yeah I used the search tool and found all the info I needed.

    Thanks
    Take each of the bolts out (after draining the coolant) and put RTV on each of them. It will be fine once it dries overnight. Don't do this and then go ride an hour later. It will leak worse. Good luck....

  5. #5
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    6,378
    +1
    981
    Since you will be sending the plate to Erik @ SFR, tell him of this situation.....it'll get fixed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. You guys rock!!!!
    By tpd in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-27-2011, 09:41 PM
  2. You guys rock
    By Looped in forum Yamaha Open Discussion
    Replies: 14
    Last Post: 06-07-2009, 12:59 PM
  3. What are you guys doing with stock parts off your ski?????
    By Jrsrxp in forum 4-Tec Performance
    Replies: 15
    Last Post: 09-30-2005, 05:57 AM
  4. what do you guys think..
    By wakeborder556 in forum 4-Tec Performance
    Replies: 9
    Last Post: 06-15-2005, 08:24 AM
  5. Have you guys checked out the portal page?
    By Green Hulk in forum 4-Tec Performance
    Replies: 6
    Last Post: 05-25-2005, 08:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •