Results 1 to 7 of 7
  1. #1

    98' GP800 Temp Sensor Question & Wave Eater Clip Check

    Howdy, new to the Yamaha side of the site.

    I just picked up a "new-to-me" 98 GP800. 114 Compression in both cylinders, 120 hours, engine compartment is a little dirty but the ski runs great. Piston wash looks beautiful.

    Two quick questions:

    Temp Sensor - I noticed it's currently installed in the head. There seems to be a port in the muffler too. A search shows photos with it installed in both places and I did notice this thread: http://www.greenhulk.net/forums/showthread.php?t=102814 Want to confirm that I should move it from the head to the muffler?

    Wave Eater Clips - Owner didn't know if wave eater clips had been installed but he "thought so". From what I've read, this is a must. And on the GP800 the entire exhaust has to come out to install them (meaning new exhaust gasket). Anyone have any luck checking one of the powervalves without removing the exhaust (I'm being cheap, I admit it). Is there something in there that needs to be removed prior to installing the clips, or just clip them on and go? Couplers necessary as well??

    Thanks in advance!


  2. #2
    slothman's Avatar
    Join Date
    May 2011
    Location
    Hell
    Posts
    731
    +1
    30
    Quote Originally Posted by chicagoanalog View Post
    Howdy, new to the Yamaha side of the site.

    I just picked up a "new-to-me" 98 GP800. 114 Compression in both cylinders, 120 hours, engine compartment is a little dirty but the ski runs great. Piston wash looks beautiful.

    Two quick questions:

    Temp Sensor - I noticed it's currently installed in the head. There seems to be a port in the muffler too. A search shows photos with it installed in both places and I did notice this thread: http://www.greenhulk.net/forums/showthread.php?t=102814 Want to confirm that I should move it from the head to the muffler?

    Wave Eater Clips - Owner didn't know if wave eater clips had been installed but he "thought so". From what I've read, this is a must. And on the GP800 the entire exhaust has to come out to install them (meaning new exhaust gasket). Anyone have any luck checking one of the powervalves without removing the exhaust (I'm being cheap, I admit it). Is there something in there that needs to be removed prior to installing the clips, or just clip them on and go? Couplers necessary as well??

    Thanks in advance!
    114 psi is a TAD low, how does she run in the water?

  3. #3
    Quote Originally Posted by slothman View Post
    114 psi is a TAD low, how does she run in the water?
    Runs great.....should I be concerned? I was under the impression 120 was what I was looking for and 114 seemed damn close.

  4. #4
    slothman's Avatar
    Join Date
    May 2011
    Location
    Hell
    Posts
    731
    +1
    30
    Quote Originally Posted by chicagoanalog View Post
    Runs great.....should I be concerned? I was under the impression 120 was what I was looking for and 114 seemed damn close.
    no you shouldn't be concerned...as long as the compression is even in both cylinders. between 100-105 I would say a top engine rebuild wouldn't hurt. Since your ski is running great I wouldn't worry about it.

    I have read on this model the exhaust manifold MUST be removed to remove the PVs Just remove the exhaust, remove & clean PVs, install the clips, install everything in reverse.

  5. #5
    Quote Originally Posted by slothman View Post
    I have read on this model the exhaust manifold MUST be removed to remove the PVs
    Bummer, guess I'm be buying a gasket. Appreciate the response.

    Anyone have any comment on the temp sensor?

  6. #6
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    I just rebuilt the same motor-same craft for a customer and it was in the exh pipe

    also yes mani removal to get to the pv covers... requires a gasket because the factory one will come apart

  7. #7
    Thanks to all. Will be moving the Temp Sensor and ordered and exhaust gasket.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 12F Water Temp sensor question...
    By Rescue1 in forum Kawasaki Open Discussion
    Replies: 11
    Last Post: 08-28-2016, 03:44 PM
  2. Wave eater clip question on xll 1200
    By Meen95z in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 01-28-2016, 09:26 AM
  3. Wave Eater Clips??
    By nubmturk in forum Yamaha Open Discussion
    Replies: 23
    Last Post: 06-12-2013, 08:49 PM
  4. wave eater clips for GP800
    By slothman in forum Yamaha Old School Skis
    Replies: 2
    Last Post: 07-26-2011, 10:01 AM
  5. temp sensor question
    By KiewaMike in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 01-04-2008, 06:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •