Results 1 to 8 of 8
  1. #1

    2002 Virage TXI won't stay running when I let go of the start button!!!!!!!

    I already replaced the LR503 relay. If I hold the bilge button down and then start it it will stay running. Any advice. We wanna ride this weekend!


  2. #2
    Bump for a HOPE AND DREAM!

  3. #3
    Bump for a HOPE AND DREAM!

  4. #4
    mr. happyfunbear tenjuna's Avatar
    Join Date
    Jun 2009
    Location
    Davenport, IA
    Posts
    574
    Quote Originally Posted by GopedGarage View Post
    I already replaced the LR503 relay. If I hold the bilge button down and then start it it will stay running. Any advice. We wanna ride this weekend!
    this is going to probably be useless help, but it sounds like a power or wiring issue...have you tried a new battery? any voltmeter readings to report?

    another thought: I have the same ski, and I had to send in the computer for repair right when I bought it due to some weird problems getting it to run. you may need to do the same...it's a $600 fix though. the place to send it to is in one of the FAQ threads in here somewhere. it took about 2 weeks to get it back, but ski ran no problems ever since and that was 5 years ago.

  5. #5
    Thank you For a reply! The Batt is new. Voltage is good while cranking...... Suddenly yesterday is started working. Lets just keep our fingers crossed that it stays working.

  6. #6
    mr. happyfunbear tenjuna's Avatar
    Join Date
    Jun 2009
    Location
    Davenport, IA
    Posts
    574
    when was the last time it ran before yesterday? for it to "suddenly" start running should be a cause for concern. either that or make sure you have an oar with you

    I also had another thought...check to make sure ALL of the connectors to the computer are actually good, I remember having a hell of a time to get them on and there was a screw to hold them in...make sure they are good.

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by GopedGarage View Post
    ... Suddenly yesterday is started working.

    Lets just keep our fingers crossed that it stays working.
    Problems that just 'fix themselves' are not good. You have no idea when it may next fail.

    And when it fails the next time it may not run just by holding the bilge button down. You do not want to be stranded on the water.

    Is this a fuel injected engine? Three cylinders?

  8. #8
    I have an LR503 in one my by DI skis that sometimes works, sometimes doesn't. It's possible that yours wasn't....and now sometimes is.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Polaris TXI Won't Stay Running
    By gswanson in forum Polaris Open Discussion
    Replies: 5
    Last Post: 11-08-2015, 12:51 PM
  2. 2002 virage txi won't start
    By Snomoguy in forum Polaris Open Discussion
    Replies: 4
    Last Post: 06-26-2015, 12:21 AM
  3. 2002 Virage i - will not stay running after Start button is released
    By jbetzelb in forum Polaris Open Discussion
    Replies: 15
    Last Post: 12-03-2012, 03:55 PM
  4. 2002 Virage TXI wont stay running DI
    By ncdoo in forum Polaris Open Discussion
    Replies: 17
    Last Post: 05-23-2012, 09:43 PM
  5. 2002 Virage TXI won't Start or Runs rough when Damp
    By cjohnson in forum Polaris Open Discussion
    Replies: 16
    Last Post: 07-11-2011, 11:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •