Results 1 to 4 of 4

Thread: MFD question

  1. #1

    MFD question

    I just put a working mfd in my 97 sl 1050 everything works but the light is flashing and it says there is no oil in it but the tank is full. I converted the ski to premix but like i said the tank is full is this gonna hurt anything or put the ski in limp mode and what should i do to fix it.


  2. #2
    ripcuda's Avatar
    Join Date
    May 2010
    Location
    Newman Lake, WA
    Posts
    2,389
    +1
    166
    I know on my '96 SL 780... that low oil or low fuel will limit RPMs... quasi limp mode... so I'm pretty sure yours would do the same.

    Did you disconnect the oil sensor wires somewhere? On mine... I pulled the oil tank float gauge and wired the float up so it always reads full (I premix) and it works fine... but of course... I kept all the wires connected for the sensor.

    Good luck

  3. #3
    Why keep a full tank of oil if you're premixing? Get rid of the tank and pull the sensor out and ziptie the float all the way up and tuck it out of the way somewhere.

  4. #4
    ripcuda's Avatar
    Join Date
    May 2010
    Location
    Newman Lake, WA
    Posts
    2,389
    +1
    166
    Not sure about OP's SL 1050... but on my '96 SL 780... the fuel/water separator "jar" was attached to my oil tank. So I left my oil tank in place... didn't want to try and make a new mount for the separator. I did, however, empty my tank and wire the float to "full".

    If OP did have a full tank of oil... not sure why his display is indicating "low oil" unless one of the wires came loose/disconnected or something.

    Cheers!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Newbie (lurker) MFD question
    By PiP in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-30-2008, 06:44 PM
  2. 94SL MFD - Question about turning off
    By howie099 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 07-22-2007, 12:26 AM
  3. MFD question?
    By Polaris_Nut#1 in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 07-08-2007, 09:55 PM
  4. MFD question, I might be dumb but.......
    By Tay71980 in forum Polaris PWC Performance
    Replies: 5
    Last Post: 03-28-2007, 09:52 PM
  5. mfd question
    By andy95'slx780 in forum Polaris PWC Performance
    Replies: 13
    Last Post: 12-15-2006, 08:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •