Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1
    Ryman's Avatar
    Join Date
    May 2012
    Location
    Shreveport, LA
    Posts
    42

    Help! Water coming out from around the pump!

    I just put the pump back on after changing out the wear ring. I hooked it up to the flush kit and started the engine then turned on the water. I noticed water spurting out from around the pump. I got those bolts as tight as I can get them. I'm about to pull the pump again and see if something got in the seal. Can anyone think of anything else I could have done?

    Thanks

    Ryman


  2. #2
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Thats should be the water coming out of the exhaust = normal

  3. #3
    Ryman's Avatar
    Join Date
    May 2012
    Location
    Shreveport, LA
    Posts
    42
    It's not the exhaust though...it's around the pump where it meets witht he pump shoe. I don't think that's normal is it?

  4. #4
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by Ryman View Post
    It's not the exhaust though...it's around the pump where it meets witht he pump shoe. I don't think that's normal is it?
    The pump gasket must not be on there right.

  5. #5
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    I think it might be time to pull the pump. Did you make sure the restricter (washer with a green seal around it)did not fall out.

  6. #6
    Ryman's Avatar
    Join Date
    May 2012
    Location
    Shreveport, LA
    Posts
    42
    I don't see a green seal nor do I remember seeing one when I took it apart. I also don't see a restricter on the parts diagram located here:

    http://216.37.204.203/Seadoo_OEM/Sea...e=13&A=91&B=14

    I did find some excess marine grease and the wear ring was sticking up a tad. both of wich could cause the gasket not to seat properly i suppose.

    Thanks

    Ryman

  7. #7
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    http://216.37.204.203/Seadoo_OEM/Sea...e=13&A=91&B=13
    Its # 11 in this one.
    When the pump is pulled, looking from the back to the front at the top of where the pump bolts up you will see from left to right 1 big (about the size of a quarter) and then 2 smaller holes. The big hole should have a washer looking thing with a green seal around it. The 2 smaller one should have yellowish (#9) looking seals in those holes.

  8. #8
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    The big hole is what feeds the exhaust and intercooler and when you flush the ski warm water comes out.
    The smaller ones are for the vacuum bailers.

  9. #9
    Ryman's Avatar
    Join Date
    May 2012
    Location
    Shreveport, LA
    Posts
    42
    Correct me if I'm wrong but those stay in the,ski when you pull the pump and venturi off? The only holes I have on the pump are for bolts correct? All I did was change the wear ring and water spurts out from where the pump seats into the ski right by one of the bolts. There was a little dirt in that area too.

    Is the wear ring supposed to be flush with the seal or slightly below.


    Man, I appreciate the help.

    Ryman

  10. #10
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by Ryman View Post
    Correct me if I'm wrong but those stay in the,ski when you pull the pump and venturi off? The only holes I have on the pump are for bolts correct?
    No, they are replaceable and the green one has habit of sometimes falling out.
    You need to look at the very top of the pump @ 12 oclock, 3 holes.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. pulled some mud into vx cruiser no water coming out of the top? help please
    By JoezCrown in forum Yamaha PWC Performance (4-stroke)
    Replies: 8
    Last Post: 09-08-2011, 08:28 PM
  2. water coming out from riva powercooler flushing adaptor
    By tysonfzr in forum Yamaha PWC Performance (4-stroke)
    Replies: 1
    Last Post: 07-24-2010, 06:12 PM
  3. Water coming out from inside hull??
    By Gus13letter in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 08-01-2009, 06:21 PM
  4. Water coming out the steering rod??
    By BobOnThis in forum 4-Tec Performance
    Replies: 7
    Last Post: 07-27-2008, 10:14 PM
  5. water coming out of the spark plug holes
    By big mark in forum Yamaha Open Discussion
    Replies: 22
    Last Post: 06-26-2007, 08:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •