Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25
  1. #1

    Please Help. 5700 rpm and 35mph but i have the yellow key

    just bought a 03 gtx sc and took it on the water the first time today. what a disappointment. it would only do 35 mph at 5700 +- rpm. the weird thing is that i have the yellow key. also the motor vibrates alot when touching the throttle. i bought this from a dealer and they said the yellow is the full power key.
    What could i look at? i just swapped the sc bushings for metal ones too. I am thinkink that the dealer f-d me and just put the yellow foam ring around a learners key and said its all good. please help
    EDIT... also when i accelerate it spins up to around 7500 rpm but quickly drops off the 5700


  2. #2
    Matatan tocullo's Avatar
    Join Date
    Nov 2010
    Location
    VISTA AL RIO FL
    Posts
    1,725
    +1
    69
    Pull the supercharger intake and see if you can spin the bladewithyour fingers. Your charger probably the cause.

    Good luck!

  3. #3
    i cant spin it one full rotation, only like 1/4 then it stops.
    nice busa btw

  4. #4
    Matatan tocullo's Avatar
    Join Date
    Nov 2010
    Location
    VISTA AL RIO FL
    Posts
    1,725
    +1
    69
    Quote Originally Posted by lownslow89 View Post
    i cant spin it one full rotation, only like 1/4 then it stops.
    nice busa btw
    Thanks, you might want to pull the charger to make shure the slip is set propertly and check your plugs. Someone else will shime in with more knowledge.

  5. #5
    Electronics Guru Alpheus's Avatar
    Join Date
    Aug 2010
    Location
    Lake Anna Va
    Posts
    520
    +1
    1
    The vibration makes it sound like its not running on all 3 cylinders. Did you rebuild the entire SC or just update the washers? Check the slip and change out your spark plugs. Find a dealers and have your DESS key checked out with BUDS...

    PS

    Always insist on a test ride before buying a used ski.

  6. #6
    i just changed the plugs out before the first ride too. this dealer has been really shady wih me. is there a way to check for sure if its the learner key? my buddy has a 05 gtx non sc and his shows an L on the cluster when he pits the learner in. im good with motors, been a bike mechanic for a while now. i did not fully rebuild the sc, only the washers. x

  7. #7
    skigolfnut's Avatar
    Join Date
    Jun 2009
    Location
    League City TX
    Posts
    1,979
    +1
    33
    I would tell the dealer what is going on and give them the opportunity to step up and do the right thing,
    If they don't then it is time to get nasty with them,

  8. #8
    im gonna call them tuesday first thing and explain yhe situation. not too confident though. theyre gonna give me some bs. is there any markings on the key plastic itself that would help me id it? other than just the yellow foam? i really feel they switched it.
    btw they wrote "yellow" on the yellow foam. weird

  9. #9
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Any color key can be programed to run 100% or as a learner key.
    You have to hook up the ski to buds and have that key on it to read how its programed.

    Sounds like a charger issue with the varied rpms.

  10. #10
    Matatan tocullo's Avatar
    Join Date
    Nov 2010
    Location
    VISTA AL RIO FL
    Posts
    1,725
    +1
    69
    Pull that charger and check it real good before you run on to a nightmare.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1200 xlt running max 5700 rpms and 40 mph
    By BluYama1200 in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 08-15-2013, 05:13 AM
  2. Nitro Please help WGS replaced and still Drops RPM's
    By Squirl in forum Honda Open Discussion
    Replies: 15
    Last Post: 08-25-2012, 08:34 AM
  3. please help first ski, and having issues
    By scd2747 in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 02-25-2012, 12:31 AM
  4. please help almost sunk and now wont start
    By gtxforlife88 in forum 4-Tec Performance
    Replies: 28
    Last Post: 08-15-2010, 04:02 PM
  5. Please Help, Hit rock and Scratched Gelcoat
    By Rspeed in forum Sea Doo Sport Boats
    Replies: 2
    Last Post: 09-06-2007, 06:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •