Results 1 to 6 of 6
  1. #1

    1998 Kawasaki STX 900 NO FIRE

    Ok.....i am about at the point were i want to turn this jet ski into a low movement.....deepwater......submersable rock explorer........had a beautiful 900 stx hull fall into my hands.....wasnt really planing on doing any thing with it....but a few of my friends got together with me and well.....at some point we split the cost on a nice used engine. We had the electronics no engine.....so we figured what the hell. Got every thing together no fire. Well after the first test with no fire we pulled the lanyard switch apart cleaned the contacts. Checked for volatage. Still no fire. Bought the book tried testing the cdi.....and from what we could tell the cdi "was suspect" but because we do not have "kawasaki special tool 1234-paykawaski$200 we can not be 100% sure. So we opted to buy a complete electrical box from another ski that was as told to us from the purchaser was runnig with poor compression in one cylinder. Installed whole box still no spark. Went back through...tested wires coming from stator etc by the manual...and pickup was considerd possible "suspect" so we checked and lo and behold in our vast store room we had another. Installed it and it tested good still no fire. Soo needless to say by now we are facing an intersting dilemia where should we go from here. WE have ponderd that this could be a possible grounding issue or something else but we are unsure of that at this time....we have tried each electronics box....still nothing.
    I will accept any and all ideas.....and no i am not above sacrificing a chickein on the third full moon of the new cycle and drenching the ski in the blood of the chicken while carving galic runes on the hull...but that is a last resort lol


  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    285
    I bought an 1100 engine off of Ebay that had no spark. Turns out the wiring harness had burned inside the rubber sleeve, possibly from rubbing on the exhaust. Anyway, replaced the harness and it works fine. You might also check resistance of the coils.

    While you're at it, check that the cooling water hose that goes to the flywheel cover isn't plugged. I've found two that were.

  3. #3
    hmm intersting oh well time to get the test light and the ohms meter back out lol. Yeah ive read were u posted tht about the cooling water hose being plugged before. This engine i bought for the ski doesn't have those its a newer design.

  4. #4
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    285
    According to the book it has the cooling hose for the stator. What 'newer design' engine do you have?

  5. #5
    hmm sorry was thinking of another ski i am working on right now lol....too many projects working on 4 skis a tractor at the moment....srry

  6. #6
    OK as of about 2 o' clock today I found the problem. After several weeks of work and trying several diffrent things I have poured over the wireing diagrams and absorbed as much info as i can i have tested every thing electronic several times. I for some reason had the idea that it was a ground issue possibly. I hooked up the negative of a jumper cable end to the neg on battery and hooked the other end up to the block of the engine and VOILA we have spark. So now I know the rest of the story........one peace down in several projects...NOW ON ZEB ON!!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1998 Kawasaki STX 900 to 1100 engine swap
    By raydmo in forum Kawasaki Open Discussion
    Replies: 2
    Last Post: 11-30-2014, 10:15 PM
  2. 1999 kawasaki stx 900 no spark :(
    By wildpeanuts in forum Kawasaki Open Discussion
    Replies: 2
    Last Post: 09-18-2011, 10:33 PM
  3. 1999 kawasaki stx 900 no spark
    By wildpeanuts in forum Kawasaki Open Discussion
    Replies: 4
    Last Post: 02-10-2011, 09:04 AM
  4. Kawasaki STX 900 & ZXI 900 on double trailer
    By Lineman482 in forum Kawasaki Classifieds
    Replies: 0
    Last Post: 08-11-2008, 06:59 PM
  5. Replies: 7
    Last Post: 06-16-2008, 04:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •