Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    Join Date
    Oct 2011
    Location
    Elmira Heights, New York, United States
    Posts
    84

    Speedo and trim question

    I got a 94 sl 750 and I can't get the speed to display on the mfd. where does it get it's input from to register the speed? I don't have a pin wheel on the back like my cousins ski.

    The trim will work if I jumper the motor. Now could it be the switch?


  2. #2
    Superd2K's Avatar
    Join Date
    Jun 2009
    Location
    Boise, ID
    Posts
    133
    +1
    3
    The speedo works on differential pressure. There's a clear pickup tube just under the driveshaft coupler that goes through the tube to the back of the MFD.

  3. #3
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by Expedition6901 View Post
    I got a 94 sl 750 and I can't get the speed to display on the mfd. where does it get it's input from to register the speed? I don't have a pin wheel on the back like my cousins ski.

    The trim will work if I jumper the motor. Now could it be the switch?
    The trim will only operate while the ski is running. You should also have a 3 amp fuse in the ebox that may need to be checked...

  4. #4

    Join Date
    Oct 2011
    Location
    Elmira Heights, New York, United States
    Posts
    84
    Have tried to move trim when skis running. But still nothing. I checked the fuse and it was good.

  5. #5
    David Drkvampire2001's Avatar
    Join Date
    Jul 2011
    Location
    Edgerton, Wisconsin, United States
    Posts
    2,857
    +1
    30
    Quote Originally Posted by Expedition6901 View Post
    Have tried to move trim when skis running. But still nothing. I checked the fuse and it was good.
    The trim motor could be seized up. Take it off take it apart and clean it up.

  6. #6

    Join Date
    Oct 2011
    Location
    Elmira Heights, New York, United States
    Posts
    84
    The trim motor work fine if you jumper it straight to the battery. I tried to ring out the switch but got to wait till I get home for that. I looked at the speedo and I can't see nothing wrong. Plus I'm thinking I'm mfd might be bad it's only readable some times.

  7. #7
    David Drkvampire2001's Avatar
    Join Date
    Jul 2011
    Location
    Edgerton, Wisconsin, United States
    Posts
    2,857
    +1
    30
    follow the tube thats connected to the speedo from the MFD all the way to the fitting right below the driveshaft, make sure no cracks or holes or anything, the other issues with not picking up speed is something could be stuck in the Pitot pickup, take the line off the back of the MFD and put some compressed air behind it, that should clear the line of whatever could we stuck in it.


    as far as your trim, sounds like something in the switch is broken the switch wiring, or something in the electrical box, if you feel youre switch is broken I have one that i believe works but the harness has been cut( dude didnt know how to part out a ski!) you would be able to splice them all back together though.

  8. #8

    Join Date
    Oct 2011
    Location
    Elmira Heights, New York, United States
    Posts
    84
    im going to ring out the wires tomorrow for the trim switch. when i bought this ski i got a slx 780 for parts. so i got another switch and trim motor. i will blow air in the tubes. thanks for the help.

  9. #9

    Join Date
    Oct 2011
    Location
    Elmira Heights, New York, United States
    Posts
    84
    where does the trim switch get its power from is it the yellow wire or the red/purple wire? plus what is the LR22 in the ebox?

  10. #10
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by Expedition6901 View Post
    where does the trim switch get its power from is it the yellow wire or the red/purple wire? plus what is the LR22 in the ebox?
    94 SL750 should have an LR 23 in it. This turns the stator voltage via the yellow wire into charging voltage on the red purple to keep the battery charged while running. It also is a switch which provides 12v power via the orange wire to power the trim switch.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Speedo and compass question
    By tmarsh in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 08-18-2015, 01:39 PM
  2. A few questions concerning low rpms, speedo and starting
    By JBRX00 in forum 2-Stroke Performance
    Replies: 4
    Last Post: 08-02-2011, 07:27 PM
  3. Best rider and trim position...
    By rx4pain in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 11-24-2008, 08:42 AM
  4. 96 Polaris SLT780 Trim and Speed Question
    By txstory in forum Polaris PWC Performance
    Replies: 7
    Last Post: 09-02-2008, 02:47 PM
  5. Polaris sl750 questions (waterleak and trim)
    By smittyj77 in forum Polaris Open Discussion
    Replies: 10
    Last Post: 05-24-2007, 03:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •