Results 1 to 3 of 3
  1. #1
    mloureirojr's Avatar
    Join Date
    May 2010
    Location
    Long Island NY
    Posts
    60

    RXP 2007 Riva Intercooler HELP Please

    Hi guys..I Don't know what to do with my rpx


    Last year I did all the upgrade that you see below..was great a fast sky 75.9MPH but because I'm a beginner I never did the right winterizing...I never replace the water that i Did my last flush with Anti-freeze so what happend my first start of this season with hose at my backyard I see a lot water getting inside the hull Holy crap bingo. little crack on my riva intercooler, took it out and took it to a radiator guy to weld the crack, then he tested to see if was getting water inside the intercooler he said was ok, well When I come back home I washed because was a little salty inside and then put it back at first start I realize was getting a lot white smoke just like the cars in the winter no white smoke like oil, then was misfiring a lot at high rpm, So I tought maybe there still some water inside the intercooler let take it to the water to dry it out, put in water was working nice in idle, but as long I hit the gas it will die I try and try and not sucess, now is not making white smoke anymore , So I was suspecting of the gas, but when I start engine it will work only for 3 or 4 seconds the starts misfiring a lot and then dies....I was suspecting of bad gas So I took the gas out was loke almost one year old gas Was really poor and look like whad water on gas, try to change the gas I trying to resart again same thing cranks starts for 3 seconds then dies , but comes the worse part after a couple attempts I was checking the oil and I see the oil like white looks like is mxing water and gas how the hell has water in the. engine???


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,397
    +1
    2,524
    Without a doubt you have a hole in that intercooler core and water is getting into your engine that way causing the poor running conditions and the misfire. I have seen this 100 times.

    That old first generation IC has been discontinued. Your best and cheapest fix would be to install the fizzle intercooler kit. Have a look at it here in the store
    http://www.4-tecperformance.com/inde...roducts_id=983

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,397
    +1
    2,524
    also, install a fresh set of spark plugs at the same time you install the new intercooler

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2007 Wake 215 Help.... Please!
    By Chatta Brony in forum Sea Doo Open Discussion
    Replies: 15
    Last Post: 03-24-2015, 08:04 AM
  2. Ok, am I stuck with this Riva SCOM? Help please.
    By dpracing in forum 4-Tec Performance
    Replies: 10
    Last Post: 06-10-2013, 09:09 PM
  3. 2007 rxp 215.. riva exhaust help
    By rearviewneons in forum 4-Tec Performance
    Replies: 10
    Last Post: 07-25-2011, 08:48 AM
  4. Fizzle Intercooler Help Please
    By RXP85 in forum 4-Tec Performance
    Replies: 21
    Last Post: 11-30-2009, 06:40 PM
  5. 05 RXP Stuck at 6300rpms, help please.
    By dlabonte in forum 4-Tec Performance
    Replies: 23
    Last Post: 09-07-2007, 01:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •