Results 1 to 8 of 8
  1. #1

    99 gtx ltd problem no beep and wont do anything

    i got a 99 gtx ltd and there is no beep when i plug key in dash works but wont do anything wont roll over with start button any ideas need help could it be mpem all fuses are good


  2. #2

    Join Date
    Mar 2006
    Posts
    1,829
    +1
    119
    battery, starter relay, contacts or mpem.

  3. #3
    AndinoWatercraft's Avatar
    Join Date
    Feb 2008
    Location
    Puerto Rico
    Posts
    306
    +1
    4
    check the rear box for the starter fuse. You can try to jump start it from the starter relay. If turns the relay is dead.

  4. #4

    Join Date
    Mar 2006
    Posts
    1,829
    +1
    119
    Quote Originally Posted by AndinoWatercraft View Post
    check the rear box for the starter fuse. You can try to jump start it from the starter relay. If turns the relay is dead.
    if the fuse is blown, the gauges will not function.

  5. #5
    AndinoWatercraft's Avatar
    Join Date
    Feb 2008
    Location
    Puerto Rico
    Posts
    306
    +1
    4
    upps.. You are right. forgot that fuse is like the main that supplies voltage to the system. Thanks.
    Last edited by AndinoWatercraft; 05-28-2012 at 09:39 AM. Reason: bad spelling

  6. #6
    Does it beep when you put the key on?

  7. #7

    Join Date
    Aug 2007
    Location
    East of DFW
    Posts
    244
    +1
    21
    Read first post again...

  8. #8

    Join Date
    Aug 2007
    Location
    East of DFW
    Posts
    244
    +1
    21
    Make sure the battery is in good working order and not just assuming.

    Remove cover from black box and cross the two terminals with red cables attached. If it turns the ski over and starts up with key attached, then solenoid is bad. Very common problem on most skis.

    If ski normally beeped before, you might also try pinching the DESS together where the ground straps run down to make contact with ring on post.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 99 GTX ltd dies then 2 beeps?
    By diamondwatercraft in forum 2-Stroke Performance
    Replies: 3
    Last Post: 09-02-2016, 07:14 AM
  2. '99 GTX LTD No spark
    By SteelHoover in forum Sea Doo ECU Support
    Replies: 1
    Last Post: 04-16-2015, 07:26 PM
  3. 99 GTX LTD got spark, got fuel, NO GO?
    By diamondwatercraft in forum 2-Stroke Performance
    Replies: 4
    Last Post: 05-27-2014, 08:56 PM
  4. 99 GTX Limited with dim display and no Beeps
    By JohnCiccarelli in forum 2-Stroke Performance
    Replies: 10
    Last Post: 05-21-2010, 11:38 PM
  5. 99 GTX Ltd Cutting out at high RPM
    By Picturemn2 in forum 2-Stroke Performance
    Replies: 8
    Last Post: 09-28-2007, 04:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •