Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
  1. #1

    horrible weekend. Need some help

    hey guys i just got a 2004 seadoo gtx and i test drove it all was good put it back on the trailer and that was it. we took it to the lake camping this weekend and had just problem after problem. First the trailer blew a bearing and the axle was just sitting in the hub. got that taken care of. than I get the seadoo out run it and anchor over night which everyone does over there came back and it had taken alot of water ran it to the trailer (started right up) and drained it. i got it back out ran it for awhile and no issues and than anchor it again but keep an eye on it. if it sits it takes on water but as soon as i take it out for 5-10 mins its completely empty. so i started beaching it and had no issues when we went to the sand bar and such. was gunna take it out went to put it on the trailer and was sitting on the trailer and a giant ass wave came up and literally washed me right over the side of the trailer. I caught it before it pushed it towards the ramp and scraped thank god. HOWEVER it literally ripped off one of the opas fins (right side) when it pushed it over.it broke the whole housing and all so i need to know if should replace the Opas side fins or get the block off plates. And i need to know what i should be looking for on this water issue. would like to have it back out next weekend. If i need pics i can post some.


  2. #2
    Treemn's Avatar
    Join Date
    Jun 2007
    Location
    Coral Springs FL
    Posts
    3,325
    +1
    640
    Fill up the hull on trailer with water from the hose not real full and see where the water comes out and seal leak. As far as opas some like some dont if you let a bunch of newbis ride it fix it. so it steers without power on.

  3. #3
    h2jim's Avatar
    Join Date
    Nov 2008
    Location
    Ontario Canada
    Posts
    2,063
    +1
    61
    I would say it's your carbon seal. Filling it up on the trailer will work. Personally I hated the opas so I blocked mine off. JMO.

  4. #4
    ill prolly replace for sellability but it ripped the whole damn thing off. i need the entire housing any ideas where to look for oem stuff. And how hard it is going to be to replace. i have it taken off it seems simple the only thing connected to the housing assembly is a hose. the issue is the other peice of plastic that comes from the inside that the rod sits in seems to be broken also. And i cant see where that goes to or how hard this is going to be to replace. ill fill the hull whats not "too full?" past the little tank in the bottom ? or more

  5. #5
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    you can get them used cheap most of us modders have them laying around
    mine are off an rxp so not all of my parts will work for you

  6. #6
    race24x's Avatar
    Join Date
    May 2007
    Location
    Fayette, Maine
    Posts
    1,005
    Hey shoot me an email I took mine off for block offs and I sold one side to a guy on here. I will check and see what side I have left and if you need it I can give yolu a good deal. My email is [email protected]

  7. #7
    Alright guys the water is pouring out the back nut where a shaft is coming out of. i talked to a guy taht had the SC version of mine and said to check that exact nut that sometimes they needed repacked. So how do i go about doing this

  8. #8
    h2jim's Avatar
    Join Date
    Nov 2008
    Location
    Ontario Canada
    Posts
    2,063
    +1
    61
    Take the nut off and fill it with permatex. I have both sides from my RXP opas. You can have them if you pay the shipping.

  9. #9
    jim i would really appreciate that. That would help me out a ton. i just got this thing thursday and just issue after issue i will gladly pay shipping ill shoot you a PM. also what is permatex? is that a thread lock or like a silicone?

  10. #10
    The opas paddles on the rxp are different from the gtx or rxt.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need some help guys, Lost 500rpm
    By CRS in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-15-2006, 05:24 PM
  2. need some help
    By Pettee in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 05-12-2006, 05:44 PM
  3. Need some help ?
    By RXP04 in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 04-20-2006, 04:36 PM
  4. Need some help planning a trip.
    By Pistonwash in forum Yamaha Open Discussion
    Replies: 21
    Last Post: 03-15-2006, 06:58 PM
  5. SeaDoo 3D (need some help)
    By MARKUS in forum 2-Stroke Performance
    Replies: 21
    Last Post: 02-09-2006, 05:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •