Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1

    help, engine flooded with garden hose

    ok so i went to fluch out my ski, hooked the hose up to it in my draveway and the engine filled up with wated from the waterbox. why did this happen? anybody hear of this before? cylinders are filled with water, pulled plugs and cranked it. should i drain oil? what caused water to come into engine from the waterbox?


  2. #2
    boosted-delslow's Avatar
    Join Date
    Jun 2010
    Location
    delaware
    Posts
    231
    +1
    1
    This may be a dumb question. The engine was running before your turned the water on right?

  3. #3
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    You'll definitely want to drain change and flush the oil till it comes out clean. Use cheap walmart 10w-40 to flush it and you don't need an oil filter in it to flush it.

  4. #4
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    You have to start the engine then turn the hose on run for less than a min turn hose off and then ski off. Can't just run a hose to flush without running the ski

  5. #5
    ndarimont's Avatar
    Join Date
    Jul 2011
    Location
    Aurora, IL
    Posts
    239
    Quote Originally Posted by boosted-delslow View Post
    This may be a dumb question. The engine was running before your turned the water on right?

    +1 its a dumb question but did you start the ski before turning the hose on?

  6. #6
    Quote Originally Posted by ndarimont View Post
    +1 its a dumb question but did you start the ski before turning the hose on?
    yes it was running

  7. #7
    Primary Language: Sarcasm Pony Racer's Avatar
    Join Date
    Jun 2011
    Location
    RiverShit, Ct
    Posts
    480
    +1
    28
    too much water pressure..

    only turn it on part way..

  8. #8
    h2jim's Avatar
    Join Date
    Nov 2008
    Location
    Ontario Canada
    Posts
    2,063
    +1
    61
    Right now you have to get that water out. Keep changing the oil until it's good. Like Jhill said use the cheap walmart 10w 40 to do this.

  9. #9
    looks like ill be going with a external intercooler if the motor is ok. turns out i have a leak in my stock intercooler and it wasnt coming from exhaust afterall

    Quote Originally Posted by Pony Racer View Post
    too much water pressure..

    only turn it on part way..

  10. #10
    You can actually do a boilout procedure once you crank and remove water from cylinders and replace plugs. I don't have the exact specifics at this point but the procedure is in the manual under section for water ingestion. Had to do it before.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Flushing with the garden hose
    By tbunny in forum Yamaha PWC Performance (4-stroke)
    Replies: 9
    Last Post: 05-14-2012, 04:02 PM
  2. Fugged up. Need help with routing hoses on 951 DI
    By Fast-XPL in forum 2-Stroke Performance
    Replies: 7
    Last Post: 09-16-2010, 08:43 PM
  3. Problem with exhaust hose. please help.
    By Jean-Paul in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 06-21-2010, 09:16 AM
  4. HELP!! Engine stalled while running on hose - what do I do?
    By way2much2do in forum Polaris Open Discussion
    Replies: 7
    Last Post: 06-27-2009, 10:55 PM
  5. Help!!! Engine Compartment flooded!!!
    By fred85 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 09-23-2007, 08:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •