Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1

    Join Date
    Jun 2010
    Location
    Sylvania, OH
    Posts
    5

    2005 RXP Blew Something HELP!

    Hey everyone I am newer to the site I read a lot on here but never really post much, but now I am in a major squeeze.

    I reached 115 hours on my 2004 RXP with no supercharger rebuild so I had it rebuilt over the winter before the washers blew. I had about 4 hours on the newly rebuilt supercharger and I heard it give out, and the whistle of the supercharger was completely gone so I took it in. I spoke with the mechanic after he tore it apart and he told me they did everything right and that one of the "MAG" screws came loose and blew through the supercharger and then through the engine.

    Have any of you guys heard of this happening? I have been searching this site and all over the web for something similar to what he said and I cant seem to find anything. I just want to make sure that I am not being fed a BS story so they dont have to fix it under warranty. They said 2000-2500 to fix it as well.


  2. #2
    formerly Gold06RXP Turbo Nick's Avatar
    Join Date
    May 2007
    Location
    Dayton, OH
    Posts
    2,095
    +1
    97
    I think one of the flywheel bolts broke sounds like. 04s Are known to have an issue with the bolts. There is an upgrade available for them. At this point your gonna have to pull the engine and clean out all the copper winding from the stator which was probably trashed by the broken bolt or bolts. Its gonna be real expensive to pay someone to fix it right. The blt breaking has nothing to do with the SC being rebuilt

  3. #3
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Miami, FL
    Posts
    2,419
    +1
    10
    That's their fault for not torquing it correctly and not adding locktite. Tell them that the ski was fine for 115 hours but 4 hours after they touched the ski it went. Ask them to what torque they set the nut to and if they don't say 22lbs(or something close, someone correct me if I'm wrong since I deal with turbos now lol) then that will tell you how bad of a job they did.

  4. #4
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Miami, FL
    Posts
    2,419
    +1
    10
    By "mag" you mean magneto? If so then disregard my previous comment and read Gold06rxp's comment.

  5. #5
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    I agree with shark.
    They torqued it too much or too little.
    Stealerships suck at mechanic work.

  6. #6
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    the mag bolts hold the mag and flywheel and mag parts can not go through the SC
    You need to look at the SC
    If the wheel is damaged it is the stealerships fault
    the only thing that could be damaged on the SC by the mag braking would be the gear
    But if the mag bolts broke you can save big money using used parts to fix it
    $ 2000+ is big money for a mag repair job
    yes a fresh SC could brake the (old style) weak mag/flywheel bolts

  7. #7

    Join Date
    Jun 2010
    Location
    Sylvania, OH
    Posts
    5
    Hey guys thanks for the fast responses! skidoochris and gold06rxp what you guys are saying makes sense. My understanding from what your saying though is it shouldnt need a new sc? The mechanic told me it def needed a new sc and the engine needs pulled. Is that correct? skidoochris i see your located near Flint, MI, that isnt very far from me. Is there somewhere that you take your stuff to have worked on?

  8. #8
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    Sorry I can’t recommend any one
    mag/flywheel damage leaves a big mess in the motor
    you could pull the mag cover off in the ski and take a look at the damage

  9. #9
    HardmanGT's Avatar
    Join Date
    Aug 2009
    Location
    Rutherfordton, NC
    Posts
    459
    +1
    3
    I am guessing that they only pulled the supercharger and rebuilt it. The flywheel (mag) bolts never would have been touched so I can't see how the dealership would be responsible. The flywheel bolts are a known failure issue in the older skis and it is recommended to replace them with the updated bolts. I think you have an unfortunate coincidence that the failure happened so close to the supercharger rebuild.

    On the other hand, there is no physical way for debris to make it into the supercharger from the engine side unless the bearing and shaft came out. I could imagine the bolt getting wedged in the flywheel to scer gear area and causing carnage.

    I guess we need some more info. Pics would tell us a lot.

  10. #10

    Join Date
    Jun 2010
    Location
    Sylvania, OH
    Posts
    5
    Well I took the ski to another "shop" and had them take a look at it.... They said the supercharger and the flywheel was shot and nothing about the mag. They rebuilt everything and replaced the flywheel. $1300 They tested it on the lake 90 minutes and had no trouble. So I picked it up and put about 4 hours on it and once again the supercharger whistle was gone and it had no where near the power. So I got towed in and took it back to the shop and hopefully they cover it under some sort of "warranty". I dont know what to do with it anymore. I think i will probably end up selling it.... Unfortuneatly. I took the seat off and looked at it and everything looked fine but due to my lack of experience I didnt take anything apart. Any ideas????

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2005 rxp wont start! help!
    By kjv86' in forum Open Discussion
    Replies: 3
    Last Post: 07-29-2013, 01:06 PM
  2. 2005 RXP - Wont run HELP!
    By cdimmick in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-13-2010, 09:45 AM
  3. need help with 2005 rxp
    By qtszx14 in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-05-2009, 08:37 PM
  4. Need Diagnostic Help -- 2005 RXP
    By JFizzleJR in forum 4-Tec Performance
    Replies: 25
    Last Post: 06-18-2009, 04:37 PM
  5. 2005 RXP Stage III Header/Manifold meltdown HELP
    By inteljd in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 06-03-2007, 12:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •