Results 1 to 5 of 5
  1. #1

    Join Date
    Jul 2011
    Location
    Phuket, Thailand
    Posts
    25

    Servicing from drive shaft to pump?

    Hi,

    Once again I'd like to tap into this board's knowledge and ask for some tips.

    I have a 2004 GTX Wake with the 155hp 4 Tec engine. I've been doing the maintenance myself so far like the oil change etc. but what I'd like to know if there is anything that needs to be done from the drive shaft starting from the engine inside the hull all the way out to the pump on the outside of the hull. I'm sure something needs to be greased or oiled here but I just don't know what. Thanks for your help in advance and do let me know if anything else needs attention as well. Thanks.


  2. #2
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    How many hours on the ski?

  3. #3

    Join Date
    Jul 2011
    Location
    Phuket, Thailand
    Posts
    25
    My ski is at around 35 hours at the moment. I know, it's barely been used in 8 years!

    Is there anything that needs attention in that area now? If not now, at what hours and which specific areas need servicing?

    Thanks.

  4. #4

    Join Date
    Jul 2011
    Location
    Phuket, Thailand
    Posts
    25
    Anyone? Anything needs to be done from shaft to pump? Lube?? Oil? Anything needs changing or regular servicing?

  5. #5
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    I'd pull the pump and the nose cone off of the pump and check your grease to see if a seal is bad. Sometimes when they sit the oil seals in the pump can go bad. I would pull the nose cone off. Remove the 3 hex bolts and pry evenly with a small flat head screw driver to remove the cone. If the grease is white black or grey you have a leak. If it is golden in color, you are ok. Reinstall the cone with a twisting motion as you will not pinch the o-rings.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 06 GTX Wake, Big leak from drive shaft after pump replacement
    By blorgfreth in forum 4-Tec Performance
    Replies: 10
    Last Post: 08-13-2015, 07:31 AM
  2. Part possibly missing from drive shaft MSX 140
    By suparoo in forum MSX/Matrix
    Replies: 8
    Last Post: 02-24-2010, 09:51 AM
  3. Drive shaft to prop problem? RPM down. *PICS*
    By KeithKman in forum 4-Tec Performance
    Replies: 22
    Last Post: 06-10-2008, 03:07 PM
  4. Impeller Seperated from drive shaft, Help!
    By Mccoy in forum 4-Tec Performance
    Replies: 55
    Last Post: 05-05-2008, 11:38 AM
  5. gpr, instal shaft to pump
    By born riding in forum Yamaha How To & FAQs
    Replies: 0
    Last Post: 12-24-2007, 01:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •