Results 1 to 9 of 9
  1. #1
    planiack's Avatar
    Join Date
    Apr 2009
    Location
    Punta Gorda
    Posts
    181

    2006 GTX Does not start after taking on water

    I have a 2006 GTX that took on water. there was a meltdown at the MPEM and the connecting wiring harness. Those have been replaced. Went to start the ski, it started but would not accept much throttle without stalling. Now it will not start at all. it has spark at all the plugs but no injector pulse at any injectors. All the fuses are good and there is battery voltage at the injectors. My question is, did the ECM go bad or is there a sensor that controls injector pulse and not spark. Thank you.
    Mike


  2. #2
    myown1manarmy's Avatar
    Join Date
    May 2012
    Location
    Noblesville, Indiana, United States
    Posts
    164
    +1
    13
    test your fuel pressure make sure you have good gas and good compression

  3. #3
    planiack's Avatar
    Join Date
    Apr 2009
    Location
    Punta Gorda
    Posts
    181
    Fuel pressure is good. So is the fuel and the compression.

  4. #4

    Join Date
    May 2011
    Location
    Florida
    Posts
    204
    How much water did you take on?

  5. #5
    planiack's Avatar
    Join Date
    Apr 2009
    Location
    Punta Gorda
    Posts
    181
    The water came up about 2 inches from the bottom of the MPEM. I am wondering if there is a sensor that may be bad. The ski has spark but no injector pulse. It will run if I squirt fuel into the throttle body. is there a sensor that is only for injector pulse or does the injector pulse rely on the same sensor as the ignition system.

  6. #6
    LPG256's Avatar
    Join Date
    May 2009
    Location
    NOBLESVILLE, IN
    Posts
    77
    +1
    6
    Has the unit been re programmed thru BUDS? If the mpem was replaced and not programmed to talk to the ECM, you'll have these issues. The Can-doo system isn't all it's cracked up to be.

  7. #7
    planiack's Avatar
    Join Date
    Apr 2009
    Location
    Punta Gorda
    Posts
    181
    I hope I am using the correct terminology. I replaced the unit by the battery. Is that the MPEM? Not the unit that mounts on the intake manifold. What is that called?

  8. #8
    Quote Originally Posted by LPG256 View Post
    Has the unit been re programmed thru BUDS? If the mpem was replaced and not programmed to talk to the ECM, you'll have these issues. The Can-doo system isn't all it's cracked up to be.
    Nonsense. The MPEM on an '06 doesn't get "reprogrammed to the ECU", it only needs to get the ski settings set for that model (like lake temp sensor, compasss, VTS, etc), which have nothing to do with his problem. However, the cluster does need to be married to the ECU for the ski to start on an '06. This can be done with the Candoo system.

  9. #9
    Quote Originally Posted by planiack View Post
    I hope I am using the correct terminology. I replaced the unit by the battery. Is that the MPEM? Not the unit that mounts on the intake manifold. What is that called?
    The MPEM is by the battery, the ECU is on the intake manifold.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1996 Seadoo spx wont start after sitting on water
    By pwcnick in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 07-12-2012, 07:26 AM
  2. 2006 seadoo gtx supercharged taking on water
    By Bdecker50 in forum 4-Tec Performance
    Replies: 13
    Last Post: 06-26-2012, 07:38 PM
  3. SLT 700 96 Not starting after running ok
    By BeachBum in forum Polaris Open Discussion
    Replies: 4
    Last Post: 08-05-2008, 12:44 PM
  4. Waverunner XLT 1200 won't go over 20 MPH after taking on water
    By mmr11408 in forum Yamaha PWC Performance (2-stroke)
    Replies: 22
    Last Post: 07-07-2008, 06:04 AM
  5. does the rxp take on water easily??
    By CarFanatic in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 05-30-2006, 08:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •