Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13

Thread: 99 Polaris slx

  1. #1

    99 Polaris slx

    I recently purchased a 99 slx, it is a little hard to start but I figure that's just being a two stroke.

    When I'm leaving the wake zone and hit the gas the engine wants to die, if you kinda feather the gas it will get up and run fine. This is how it is any time you stop.

    I don't know anything about jet ski's and just the basics about engines but my best guess I that the carburetor needs adjusted or rebuilt.

    Any advice is greatly appreciated.


  2. #2
    Rebuild the carbs and replace the fuel lines

  3. #3
    I transcend race Hombre! TBone14's Avatar
    Join Date
    Jan 2011
    Location
    St. Louis, MO
    Posts
    944
    +1
    7
    +1

    Use only genuine Keihin rebuild kits - they are more expensive, but much more reliable.

    John Zigler at Rock County Jetski (www.watcom.com) can hook you up with the parts.

  4. #4

  5. #5
    My same jetski..run fine with no throttle, but if try to go slow speeds it bogs but when kick in the throttle it is like super fast..no problems..it does not like to go slow..but I hear that is just how the skis are

    Quote Originally Posted by Shockwave View Post
    I recently purchased a 99 slx, it is a little hard to start but I figure that's just being a two stroke.

    When I'm leaving the wake zone and hit the gas the engine wants to die, if you kinda feather the gas it will get up and run fine. This is how it is any time you stop.

    I don't know anything about jet ski's and just the basics about engines but my best guess I that the carburetor needs adjusted or rebuilt.

    Any advice is greatly appreciated.

  6. #6
    Interesting. I am dropping it off at the shop today to have them take a look at it.

  7. #7
    Well I dropped it off and the called me today and said the stator is out and that there is none available for it.

  8. #8
    Polarisitis loonatik's Avatar
    Join Date
    May 2010
    Location
    Tampa, FL
    Posts
    812
    +1
    10
    Quote Originally Posted by Shockwave View Post
    I recently purchased a 99 slx, it is a little hard to start but I figure that's just being a two stroke.

    When I'm leaving the wake zone and hit the gas the engine wants to die, if you kinda feather the gas it will get up and run fine. This is how it is any time you stop.

    I don't know anything about jet ski's and just the basics about engines but my best guess I that the carburetor needs adjusted or rebuilt.

    Any advice is greatly appreciated.
    This symptom points to problem in the carbs, fuel delivery system. Not sure why the shop says it's the stator. If stator is out it would neither run nor run fine at all.
    There's wealth of info in this forum but only it benefits someone who would do his own wrenching/testing. Since yours is in the shop, it's gonna be hard to tell them what to do.

    Just FYI. There's no replacement available for yours but you could use electrical 'update kit' from 1998 SLXH model.


    Quote Originally Posted by K27viper View Post
    My same jetski..run fine with no throttle, but if try to go slow speeds it bogs but when kick in the throttle it is like super fast..no problems..it does not like to go slow..but I hear that is just how the skis are
    Mine runs great in all power range. Proper carb settings/cleaning is all you need.

  9. #9
    skigolfnut's Avatar
    Join Date
    Jun 2009
    Location
    League City TX
    Posts
    1,979
    +1
    33
    It could be the stator, I had a 1997 785 pro that ran great, then one day it would run for a little bit, then not start, I would let it sit, then it would run fine for a while, then back to only slow idle, I took it to Gene's in Baytown where the mechanic Matt who used to race on the Polaris team said it was the stator,
    and sure enough I changed it out the stator and presto it runs great now,

  10. #10
    Polarisitis loonatik's Avatar
    Join Date
    May 2010
    Location
    Tampa, FL
    Posts
    812
    +1
    10
    Quote Originally Posted by skigolfnut View Post
    It could be the stator, I had a 1997 785 pro that ran great, then one day it would run for a little bit, then not start, I would let it sit, then it would run fine for a while, then back to only slow idle, I took it to Gene's in Baytown where the mechanic Matt who used to race on the Polaris team said it was the stator,
    and sure enough I changed it out the stator and presto it runs great now,
    The reason for my doubt because OP described a different symptom than yours. Then again the OP may not have described it exactly

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 99 Polaris SLX oil pump block ?
    By martin6037 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 03-15-2013, 09:00 PM
  2. 99 Polaris SLX 1050 problem
    By clay1191 in forum Polaris Open Discussion
    Replies: 12
    Last Post: 01-25-2012, 09:11 PM
  3. FS 99 Polaris SLX 1050 $1500
    By electricgeoff in forum Polaris Classifieds
    Replies: 2
    Last Post: 08-23-2011, 11:43 AM
  4. FS 99' polaris SLX $1500
    By electricgeoff in forum General Classifieds
    Replies: 1
    Last Post: 08-18-2011, 12:59 PM
  5. Q: about the '99 Polaris SLX
    By SideFX in forum Polaris Open Discussion
    Replies: 3
    Last Post: 04-06-2008, 02:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •