Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16

Thread: Only 75mph?

  1. #1

    Join Date
    Apr 2008
    Location
    Norway
    Posts
    25
    +1
    1

    Only 75mph?

    Hello i have a 08 rxp-x with some mods and only hitting 75mph

    4" inntake fizzle
    sea doo centre autstralia ecu 8400
    New c kit supercharger
    riva pistons
    Riva intercooler
    Opas block offs
    r&d aquavein inntake
    Riva wedge kit
    riva reduction ring 82mm
    valvetrain kit
    Riva catch can kit
    riva steel wearring
    solas 15/22r
    riva blow off valve
    Riva thermostat kit

    Should i not see 80?

    I dont have a afr


  2. #2

    Join Date
    Apr 2008
    Location
    Norway
    Posts
    25
    +1
    1
    And a 3" exhaust

  3. #3
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    You have enough to do 80. Just need to check AFRs and and tune up the whole set up.

    I would get rid of the BOV. Change the RIVA 82mm nozzle to a OEM RXP 83mm exit nozzle. Did you get a adjustable VTS rod? If so you need to adjust it for speed. Your AFRs maybe lean. What RPMs are you hitting at WOT on smooth water?

    Your AFRs are very important. You do have RIVA pistons which can take being lean. But you can damage the exhaust valves, guides, and valve seals by running too lean.

  4. #4
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    And break rings running lean

  5. #5
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Quote Originally Posted by jhill19 View Post
    And break rings running lean
    The ring gap is done right and piston to cylinder is right shouldn't be a problem unless he is very, very lean. Hope he is running good fuel with that C-Kit, though. He may already have a blow headgasket, especially if he was on the rev limiter.

  6. #6

    Join Date
    Apr 2008
    Location
    Norway
    Posts
    25
    +1
    1
    Ok, why get rid of the bov?

    Is it posible to only change to the 83mm ring?

    I have a adjustable vts rod, do you have any recommendations?

    I hit 8360-8400 at wot

    What do you think i hit with new injectors and 8600-8700 ecu?
    Is it safe?

    Thnx

  7. #7

    Join Date
    Apr 2008
    Location
    Norway
    Posts
    25
    +1
    1
    Quote Originally Posted by jp1300r View Post
    The ring gap is done right and piston to cylinder is right shouldn't be a problem unless he is very, very lean. Hope he is running good fuel with that C-Kit, though. He may already have a blow headgasket, especially if he was on the rev limiter.
    The ski has 105 hours with the c kit and 25 hours with te riva pistons. Blown headgasket 1 time.
    I have bought afr gauge, boost gauge and temperature.

    Only need the tapping in the manifold now

  8. #8
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Quote Originally Posted by mavoma View Post
    Ok, why get rid of the bov?

    Is it posible to only change to the 83mm ring?

    I have a adjustable vts rod, do you have any recommendations?

    I hit 8360-8400 at wot

    What do you think i hit with new injectors and 8600-8700 ecu?
    Is it safe?

    Thnx
    Yes you can try the 83mm RIVA ring, just like the OEM RXP nozzle. You will find out why, if the ring spits out of the exit nozzle.

    Sounds like you are on the limiter. Bad, this will blow a headgasket in a split second.

    What valvetrain kit do you have?

    Been running at least 9.1 LC ecus for a few years now. I can tell you the stock pistons can't take high boost, poor fuel, being lean or a bad intercooler.

    I adjust my VTS rod to be fastest for me when its all the way up. I try to get the bottom of the steering nozzle even with the bottom exit nozzle. Its something you have to play around with.

  9. #9

    Join Date
    Apr 2008
    Location
    Norway
    Posts
    25
    +1
    1
    I run LIght weight retainers and springs, dont know what type.

    What do i need to do with my High rpm? Prop work?

    I need to mount that afr know, do you use O2 or widebandsensor?

  10. #10
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    sounds like people shoud stay away form a ecu that detos at the rev limiter
    a wideband sensor is a o2 sensor

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Whooops... only getting 116 compression!?
    By Phil in forum 4-Tec Performance
    Replies: 7
    Last Post: 09-04-2005, 03:55 PM
  2. Limited run of STX15 R SC, 240, current hull, USA only
    By 11 in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 08-23-2005, 09:50 PM
  3. Water filled in the hull, RXP only 10hrs...
    By omelfata in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 08-15-2005, 02:39 PM
  4. Replies: 4
    Last Post: 07-14-2005, 09:38 PM
  5. why "only" 69.22 MPH?
    By Ed in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 05-29-2005, 11:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •