Results 1 to 7 of 7
  1. #1

    Join Date
    May 2012
    Location
    Stoney Creek, ON Canada
    Posts
    3

    2005 GTX Supercharged - Dreaded Oil Light Strikes Again

    I have a 2005 GTX SC I bought last year and has never worked properly since. Every time I put it in the water and get it up to 4000rpm the low oil warning comes on and the engine starts to chug when I give it gas. After about 10-15mins of idleing the oil light goes off and it works fine. I've checked the oil and there is enough in there. The only other time the light came on was briefly when I gave it full throttle doing some sharp cornering.

    I've had both oil pressure switches changed(front and back) and still the oil light comes on. I had the ski hooked up to BUDS and no codes or codes in memory of the onboard computer. I'm reading on the forums that it might be the spring in the oil pump might be stuck open or closed. Also I'm at 97.5 hrs and due to have the supercharger rebuilt. Not sure of the history or maintenance of the machine but it may very well still have the ceramic washers still in the supercharger.

    Would the supercharger have anything to do with the oil light coming on or should I be looking more to the oil pump?

    Any suggestions would be greatly appreciated,


    Thanks


  2. #2
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    I've seen this happen when the screens on the oil pumps were plugged.
    It was a 08 rxtx that had pieces of a stator stuck in the screens.
    The prior owner of this rxtx put in a new stator but didn't clean out the screens on the oil pumps.
    If you don't know the history of the ski its hard to tell if this could be your issue.
    Only way to get to the screens is to pull the motor.

  3. #3
    Autism Speaks. Its Time To Listen gOt BoOsT's Avatar
    Join Date
    May 2011
    Location
    Cali
    Posts
    1,413
    +1
    51
    id try adding oil. after i did my service i added alomst the whole jug of oil and thought it was enough...went out and second wot oil warning/limp mode. added rest of jug and it was happy. gotta check the dipstick hot and on the water for most accurate reading

  4. #4

    Join Date
    May 2012
    Location
    Stoney Creek, ON Canada
    Posts
    3
    As far as I know and can see everything looks original inside. No work has ever been done.

  5. #5

    Join Date
    May 2012
    Location
    Stoney Creek, ON Canada
    Posts
    3
    Trust me, I've checked the oil about 30 times. Hot, cold and on the water. I'm possitive that the oil level is not the issue.

  6. #6
    I see there are a lot of threads on this subject, and at least four proposed solutions: pressure sensors, more oil, oil pressure spring, and oil pump screens. I wonder if various machines are experiencing different causes for the same low-pressure warning? It appears that different fixes work for different people.

  7. #7
    PimpjuiceII's Avatar
    Join Date
    Jun 2008
    Location
    Huntingdon Valley, PA
    Posts
    8
    Change the oil and filter. Your timing cover is leaking coolant into your oil and causing a sludge which collapses your oil filter. Very common problem. I guarantee if you check your oil filter and it is sucked in, you found your problem. I just went through the same shit, spent a ton of money replacing all kinds of stuff till Wildwood SeaDoo told me about this problem, sure enough I pulled my filter and it was sucked in. But if that's your problem, get the leak fixed, I made the mistake of riding it and just locked my motor up after about 3 full tanks of riding since replacing the oil filter. Sucks!!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 9
    Last Post: 04-29-2013, 05:43 PM
  2. 2003 gtx supercharge losing oil??
    By Bsu93seadoo in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-07-2012, 01:29 PM
  3. Lighting strikes again Jim
    By Rocketman in forum Yamaha PWC Performance (4-stroke)
    Replies: 18
    Last Post: 07-03-2010, 02:34 PM
  4. Looking to buy 2005 GTX Supercharged
    By prunyon in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 07-09-2008, 10:49 AM
  5. 2003 GTX 4Tec SC Oil Light prob.
    By 03gtx01 in forum 4-Tec Performance
    Replies: 11
    Last Post: 06-10-2008, 08:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •