Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    Join Date
    May 2012
    Location
    Lincoln, NE
    Posts
    4

    Seadoo RXT cavitation/top end RPM Loss

    I have a 2006 seadoo RXT. The water temp is around 70 degrees and right after leaving the ramp my ski will run around 7400rpms then it will decline to 7100 rmps. What should my ski be running. Im also confused because the MPH are only around 50 but i know from riding with other skis that its about 10 mph faster than that. Im also experiencing major cavitation from a dead stop. Im not sure if my top end problem and the cavitation are related but your advice of what to look at for an issue would be greatly appreciated. This past winter i put the O.P.A.S. block off kit thinking that would help my top end but no luck although my ski handles like its on rails.


  2. #2
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    how many hours on the SC brp recomends a rebuild at 100 hours
    have you checked the boost hose it could be bad or have loose clamps
    have you looked at the prop and wear ring yet?

  3. #3

    Join Date
    May 2012
    Location
    Lincoln, NE
    Posts
    4
    It has 78 hours on the ski. the prop and wear ring both look fine when i checked them. where is the boost hose located?

  4. #4
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    the hose from the SC to the intake mani
    I had one split on mine

  5. #5

    Join Date
    May 2012
    Location
    Lincoln, NE
    Posts
    4
    ok i will check that tomorrow. do you have any suggestions on my cavitation problems?

  6. #6

    Join Date
    May 2012
    Location
    Upstate NY
    Posts
    111
    +1
    2
    I would double and triple check that prop and wear ring again. That's usually the cause of cavitation. But could also be a carbon seal issue. But definitely look at the pump again before you start tearing into other things to solve the cavitation issue.

  7. #7
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    carbon seal and bellows. I'd pull the pump just to be sure on the wear ring and prop.

  8. #8

    Join Date
    May 2012
    Location
    Lincoln, NE
    Posts
    4
    Im still confused on what is causing my top end rpms to drop. If im easy on my rxt and drive about half throtle then get after it it will rap up to around 7400 rpms but then shortly after it begins to drop. Its almost seems that its temp

  9. #9
    i was having some very bad cavitaion problems on my 05, i found that some of the Teeth on the pump support where broken, pulled the pump and cut them off with a razor knife and used a dremel and sanded them down smooth, look up though intake grate and you can see the "teeth" i also found that the rubber boot from the impeller to the drive shaft was missing, in all since i had it all apart, i replaced the carbon seal and boot, (i also put a large oring behind the boot to keep more tension on the seals) added the missing drive shaft to impeller seal and cleaned up the pump support. what a differance this made. to help with removing the carbon seal top, i used a 1 1/2 wrench and ablock of wood against the charger for leverage was able to pull top back and remove clip by my self.

  10. #10
    jheyde's Avatar
    Join Date
    Dec 2008
    Location
    Mansfield,OH
    Posts
    40
    If you're dropping RPM's like that, I'd check that SC slip. Are you out of the water a lot? I know I am, and I definitely was in need of a rebuild at 85 hours. I know I had cavitation issues, and I'm sure it was because I had an "ebay" wear ring laying around I put in, and my tolerances were way high. Check that wear ring and any abnormalities in the pump.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Seadoo 787 New top end, BURNING THROUGH OIL !
    By topfli8979 in forum 2-Stroke Performance
    Replies: 7
    Last Post: 07-07-2013, 01:29 PM
  2. Seadoo xp 800 top end rebuild
    By topfli8979 in forum 2-Stroke Performance
    Replies: 7
    Last Post: 06-30-2013, 09:35 PM
  3. SOLD SeaDoo RXT Riva Top-Loader Intake Grate
    By gbayus in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 02-12-2013, 05:42 PM
  4. 99xl 1200 top end power loss????????
    By dirtyd99xl12 in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 04-25-2011, 08:10 PM
  5. FS Seadoo 951DI Complete top end with cylinder
    By Wetracer in forum Sea Doo Classifieds
    Replies: 5
    Last Post: 12-16-2009, 04:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •