Results 1 to 7 of 7

Thread: Power Loss

  1. #1

    Power Loss

    Hello, I have a 2004 GP 1300R jetski and I am having some problems with it and hope that someone has some suggestions. It sat for four years without any use. When I started to take it out the intake water grate broke (Again) and I was never able to reach max speed. At first I thought it was because of the massive amounts of fresh water that was leaking into the ski. So, I took the entire intake grate out and then put new fiberglass on the entire back end where the water was coming into the ski. Now, the ski isn't taking on any water and it is still not reaching max speed. The highest speed it goes is between 45-50 mph. The compression is good in all three cylinders, but the motor does bog at times. At top speed it feels like it is falling on it's face. Any suggestions would be appreciated. no check engine light on or anything. Where should I start? Is it a fuel problem? I don't even know if you can test the fuel pump. I checked the air intake and I can't even find a filter to clean out. Thank you for reading, I really need the help.


  2. #2
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    Quote Originally Posted by quinn.jeremyz View Post
    Hello, I have a 2004 GP 1300R jetski and I am having some problems with it and hope that someone has some suggestions. It sat for four years without any use. When I started to take it out the intake water grate broke (Again) and I was never able to reach max speed. At first I thought it was because of the massive amounts of fresh water that was leaking into the ski. So, I took the entire intake grate out and then put new fiberglass on the entire back end where the water was coming into the ski. Now, the ski isn't taking on any water and it is still not reaching max speed. The highest speed it goes is between 45-50 mph. The compression is good in all three cylinders, but the motor does bog at times. At top speed it feels like it is falling on it's face. Any suggestions would be appreciated. no check engine light on or anything. Where should I start? Is it a fuel problem? I don't even know if you can test the fuel pump. I checked the air intake and I can't even find a filter to clean out. Thank you for reading, I really need the help.
    sitting for 4 years you might have clogged fuel injectors.

  3. #3
    Thanks for the suggestion, I will try to take it apart this weekend and clean them. I hope this is the solution!

  4. #4
    Altezza01's Avatar
    Join Date
    Jun 2007
    Location
    Destin, FL
    Posts
    1,527
    +1
    13
    could also be the fuel filter

  5. #5
    Quote Originally Posted by Altezza01 View Post
    could also be the fuel filter
    I pulled out fuel pump and looked at the filter which looks just like a sock and it isn't dirty or clogged. I can't get to anything else inside it. Am I mistaken?

  6. #6
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    Quote Originally Posted by quinn.jeremyz View Post
    I pulled out fuel pump and looked at the filter which looks just like a sock and it isn't dirty or clogged. I can't get to anything else inside it. Am I mistaken?
    no you are correct all it has is a strainer on the bottom of the pump that looks like a sock.

  7. #7
    Click image for larger version. 

Name:	IMG_0028[1].jpg 
Views:	23 
Size:	100.7 KB 
ID:	273351Click image for larger version. 

Name:	IMG_0029[1].jpg 
Views:	20 
Size:	93.7 KB 
ID:	273352

    I took the fuel injectors apart and there wasn't anything crazy stuck inside. I even uploaded some pictures. Is there a way to test the fuel pump? Or is there a way to hook the ski up to a computer to see if there are any error codes?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help, need the experts!! 2006 RXP Power Loss
    By tampa_m5 in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 10-03-2016, 08:56 PM
  2. gpr 1300 power loss
    By nobbyq in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 04-23-2008, 04:14 PM
  3. Help with diagnosing power loss in 3D
    By Jas in forum 2-Stroke Performance
    Replies: 15
    Last Post: 12-05-2007, 10:33 PM
  4. Power loss
    By rfjr23 in forum Polaris Open Discussion
    Replies: 11
    Last Post: 08-12-2007, 01:22 AM
  5. Power loss
    By mrbtd in forum Yamaha PWC Performance (2-stroke)
    Replies: 16
    Last Post: 04-28-2007, 10:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •