Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1
    Nobody Really bling bling's Avatar
    Join Date
    Apr 2005
    Location
    Lake Lanier Georgia
    Posts
    374
    +1
    1

    Well not a pwc project but see if u like

    Before o added some blue accesories and sent my dash panels off
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	before.jpg 
Views:	47 
Size:	68.1 KB 
ID:	15015   Click image for larger version. 

Name:	before helm.jpg 
Views:	42 
Size:	54.4 KB 
ID:	15016   Click image for larger version. 

Name:	before int.jpg 
Views:	70 
Size:	58.6 KB 
ID:	15017  


  2. #2
    Nobody Really bling bling's Avatar
    Join Date
    Apr 2005
    Location
    Lake Lanier Georgia
    Posts
    374
    +1
    1
    After everything got back and installed
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSC03319.JPG 
Views:	50 
Size:	1.13 MB 
ID:	15020   Click image for larger version. 

Name:	DSC03313.JPG 
Views:	54 
Size:	1.32 MB 
ID:	15021   Click image for larger version. 

Name:	1DSC03316.JPG 
Views:	35 
Size:	81.5 KB 
ID:	15022   Click image for larger version. 

Name:	DSC03320.JPG 
Views:	42 
Size:	1.12 MB 
ID:	15023  

  3. #3
    Nobody Really bling bling's Avatar
    Join Date
    Apr 2005
    Location
    Lake Lanier Georgia
    Posts
    374
    +1
    1
    More blue
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	1DSC03312.JPG 
Views:	39 
Size:	53.7 KB 
ID:	15024   Click image for larger version. 

Name:	DSC03310.JPG 
Views:	38 
Size:	1.23 MB 
ID:	15025   Click image for larger version. 

Name:	DSC03314.JPG 
Views:	41 
Size:	1.24 MB 
ID:	15026  

  4. #4
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    Looks sweet bling. How much HP does that motor put out?

  5. #5
    Nobody Really bling bling's Avatar
    Join Date
    Apr 2005
    Location
    Lake Lanier Georgia
    Posts
    374
    +1
    1
    Quote Originally Posted by RXP Steve View Post
    Looks sweet bling. How much HP does that motor put out?
    500 ponies with the 5 pound pulley . no idea what it would do with the 7.5 pulley i got .

  6. #6
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    Thats a nice boat Bling

    how fast have you had it up to ?

  7. #7
    Nobody Really bling bling's Avatar
    Join Date
    Apr 2005
    Location
    Lake Lanier Georgia
    Posts
    374
    +1
    1
    Quote Originally Posted by RX951 View Post
    Thats a nice boat Bling

    how fast have you had it up to ?
    Thank rx951 i had it to 78 gps end of season last year and it was real loose running different prop . Changed a few things over winter and hoping i will be able to handle mid 80s . It has a pad bottom so no much boat touches water above 75 . And it is very very light which dont help at high speeds. My new prop should be back in a few weeks and it is adjusted and labbed . So we will see . Never got it out on glass water though

  8. #8
    All hail the Chief! fullboogie's Avatar
    Join Date
    Nov 2005
    Location
    Texas
    Posts
    3,155
    +1
    44
    Vortech blower? Looks like their aftercooler on there.

  9. #9
    Nobody Really bling bling's Avatar
    Join Date
    Apr 2005
    Location
    Lake Lanier Georgia
    Posts
    374
    +1
    1
    Quote Originally Posted by fullboogie View Post
    Vortech blower? Looks like their aftercooler on there.
    ATI setup m3sc and aw504

  10. #10
    THE OFFICAL SUPERDUTY!!!!!! superduty's Avatar
    Join Date
    May 2006
    Location
    Webster, Texas
    Posts
    4,726
    +1
    5
    hey bling get rid of the pioneers and put you some alpines in there

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Newb here but not to PWC's. Kawi Content.
    By keithb7 in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 02-11-2014, 09:11 PM
  2. How do I check to see if oil pump working or not?
    By Seakid in forum Polaris How To & FAQs
    Replies: 7
    Last Post: 02-04-2013, 06:22 PM
  3. NOT a pwc.. a mercrusier BUT im hoping for some help with this plug!
    By jayp0209 in forum Yamaha PWC Performance (4-stroke)
    Replies: 6
    Last Post: 05-13-2012, 06:15 AM
  4. not really PWC but holeeeee
    By rampager in forum Sea Doo Sport Boats
    Replies: 32
    Last Post: 05-06-2009, 12:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •