Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1

    Fx Sho Revving issue

    Hi Everyone! I am having an issue with my Ski... Hope someone can help. I put the wave runner in the water and it started with no issue. Hit the gas, and noticed that it was only revving to about 5300rpm. I looked under the seat to see f something had come loose, and all was normal. Now here is the thing... I put the ski back on the trailer, and hit the gas when its out of water, and it revs with no problem. Its not in L Mode. If i put it in reverse, it revs even lower than that, which tells me that its not a reverse sensor. Any ideas would be GREATLY appreciated. Thanks in advance to everyone!

    Claudio


  2. #2

    Join Date
    Jul 2005
    Location
    Central North Carolina
    Posts
    3,847
    +1
    528
    check the super charger sprag oneway clutch to see if it has gone has gone bad! Tommy Jordan

  3. #3
    Hi Tommy

    Thanks for the idea. How would i do that?

    Thanks

  4. #4

    Join Date
    Jul 2005
    Location
    Central North Carolina
    Posts
    3,847
    +1
    528
    remove the air filter hose where it ataches to the supercharger , stick your finger into the supercharger and see if the compresser wheel will turn in both directions if it turns in both directions your sprag clutch is BAD, it it turns in one direction only it is considerd to be good. Caution do not stick your finger in supercharger while the engine is running and remove the safety lanyard befor you start working on your ski for safety.

  5. #5
    Thanks again Tom, I will check it out today for sure. The strange thing is, why only in the water is it doing that and not when its on the hose or just on the trailer...

  6. #6
    YAMAHA POWAAAA !!!!! 1_Fast_SHO's Avatar
    Join Date
    Apr 2010
    Location
    Houston, Texas
    Posts
    3,144
    +1
    255
    Perform the clutch test with ENGINE OFF, if it spins both ways ur clutch is gone,. hope is not that and only a boost leak,

  7. #7
    YAMAHA POWAAAA !!!!! 1_Fast_SHO's Avatar
    Join Date
    Apr 2010
    Location
    Houston, Texas
    Posts
    3,144
    +1
    255
    It only does it in the trailer because the ski wont boost out of the water (correct me if i am wrong), Perform the clutch test with ENGINE OFF, if it spins both ways ur clutch is gone,. hope is not that and only a boost leak,

  8. #8
    So if the ski isnt hitting boost out of water, i assume its because there is no load on it. THe only thing that gets me is that it always revs to the 5200 rpm area.. I figured if it was the clutch, it would rev in different ranges sparatically no.. I assume you are talking about the supercharger clutch right? Thanks again for the help!!

  9. #9
    YAMAHA POWAAAA !!!!! 1_Fast_SHO's Avatar
    Join Date
    Apr 2010
    Location
    Houston, Texas
    Posts
    3,144
    +1
    255
    Quote Originally Posted by ClaudioS2ooo View Post
    So if the ski isnt hitting boost out of water, i assume its because there is no load on it. THe only thing that gets me is that it always revs to the 5200 rpm area.. I figured if it was the clutch, it would rev in different ranges sparatically no.. I assume you are talking about the supercharger clutch right? Thanks again for the help!!
    Exactly the engine cus theres no load, your best bet is definitely checking if the wheel spins both ways. Yes we are talking about the clutch,

  10. #10
    So this clutch failure seems to be about the only thing common that goes wrong with the super charged Yamahas. I have two 2010s with the supercharger with about 40 hours each. Is there an approximate hour these clutches usually fail? Do they fail more rapidly on modified skis?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FX SHO overheating issue
    By Ericruiz911 in forum Yamaha PWC Performance (4-stroke)
    Replies: 9
    Last Post: 06-20-2016, 05:41 PM
  2. 08 FX SHO starting issues :: Help!!!
    By roosty in forum Yamaha PWC Performance (4-stroke)
    Replies: 26
    Last Post: 04-24-2016, 06:57 PM
  3. 2011 FX SHO Engine Issue
    By Spi200 in forum Yamaha PWC Performance (4-stroke)
    Replies: 6
    Last Post: 01-27-2016, 05:29 AM
  4. 2009 Yamaha FX SHO - Any issues or concerns?
    By SCHNORR12 in forum Yamaha PWC Performance (4-stroke)
    Replies: 0
    Last Post: 04-15-2014, 06:50 PM
  5. fx sho rpm issue
    By hero in forum Yamaha PWC Performance (4-stroke)
    Replies: 10
    Last Post: 12-23-2011, 06:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •