Results 1 to 10 of 10
  1. #1

    Join Date
    Jan 2012
    Location
    Hanover, pa
    Posts
    20

    Bilge pump on 750 ss xi

    just wondering if many guys run bilge pumps on these skis. taking the ski out for the first time ever this week and just wondering if i should have one, and if so, where to run the outlet house..


  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,009
    +1
    283
    If I were going a long way from shore, I probably would. In an average lake, I don't think you'll need one.

  3. #3

    Join Date
    Jan 2012
    Location
    Hanover, pa
    Posts
    20
    I am going to run it in a river and in the Chesapeake bay area. Now in the manual it talks about the bilge system the ski already has. How does that work? Now if I do decide to put one in, where do I run the outlet line?

  4. #4
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,009
    +1
    283
    The factory setup has a tube in the low pressure section of the jet pump. This hooks to a hose that runs to a strainer in the bottom of the hull. It works great--while the engine is running. If the engine quits, so does the 'pump'.

  5. #5

    Join Date
    Jan 2012
    Location
    Hanover, pa
    Posts
    20
    oh okay thats cool. well in that case ill just run it the way it is. seems the sediment bowl is not unscrewing for me... guess the easiest thing to do is buy a new one? and can i use a universal fuel filter and take the stock one out?

  6. #6
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,009
    +1
    283
    Try a strap wrench. If that doesn't work, get some large Channellocks.

  7. #7

    Join Date
    Jan 2012
    Location
    Hanover, pa
    Posts
    20
    no success yet. soaking it in wd40 tonight.. may just have to buy a used one..

  8. #8
    demian5's Avatar
    Join Date
    May 2012
    Location
    Lake Forest, CA
    Posts
    152
    +1
    4
    My daughter rolled my 1994 750ss xi over 3 times the wrong way on sunday and it picked up about one inch of water. I blasted after that and hull was dry from the factory bilge system.

  9. #9
    agree the bilge works pretty well, no need for aftermarket. Make sure you check the Thru hull bearing every one in awhile that will be the only spot it leaks really, or well of course if your ski has a drain plug in the back make sure its screwed in tight and the rubber o-ring is good on it.

  10. #10
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,009
    +1
    283
    A garden hose washer makes a good (i.e. BETTER) replacement seal for the drain plug than the original.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. putting in a bilge pump on my 15f
    By inchadeboca in forum Kawasaki Open Discussion
    Replies: 4
    Last Post: 07-07-2008, 10:28 PM
  2. Bilge Pump on a SX-R 800
    By rollin5150 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 0
    Last Post: 03-23-2008, 02:05 PM
  3. help me how to install bilge pump on gp1200r-02
    By uziwork in forum Yamaha How To & FAQs
    Replies: 1
    Last Post: 07-04-2007, 10:01 AM
  4. Electric Bilge Pump on U 250X
    By earthshaker in forum Kawasaki PWC Performance (4-stroke)
    Replies: 36
    Last Post: 06-27-2007, 02:58 PM
  5. Bilge Pump on RXP
    By WATER BONER in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 08-31-2006, 08:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •