Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
  1. #1
    Carbonic's Avatar
    Join Date
    Sep 2011
    Location
    Omaha, Nebraska
    Posts
    448
    +1
    32

    Rough day at the lake

    Towed a boat and two skis to the dock, watched two guys moving about 50 wipeout on a ski so I picked one up to get him out of the boat traffic and he looked pretty rough so hopefully he's fine, dropped a phone in the water, watched my rpm's drop to 5800 and no power, had a trailer light out so I got pulled over coming home and tomorrow it's back to work.

    I'm hoping the rpm drop is just a vaccum issue. I checked the SC wheel and could only spin it one way (If I tried hard enough it would move a bit the other way). Should there be absoloutly no movement regardless of how hard you try to spin it if the clutch is still good? There is no free play both ways so I'm assuming it's ok.

    When it happened I opend up the throttle a couple of times to see how my RPM's were and it was usually in the 5800 range. I hit some wake and then went up to 6100 so I though maybe something was loose causing a leak. I havent found anything yet but I'm not sure about that j pipe going from the IC to the throttle body, it's kind of hard to check with any certainty, atleast short of reseating it to make sure it's on there.

    Guess I'll go dig around some more and see what I can find. Found the phone too and suprisingly it works after about an hour in the water..


  2. #2
    Yellow93's Avatar
    Join Date
    Apr 2006
    Location
    San Antonio, Texas, United States
    Posts
    2,429
    +1
    122
    Wow what a day! Hopefully the ski is something minor.

  3. #3

    Join Date
    Jul 2005
    Location
    Central North Carolina
    Posts
    3,846
    +1
    527
    the supercharger wheel should not move in the lock direction at all, if it slips or rotates any in the lock direction it is Bad> Tommy Jordan

  4. #4
    Carbonic's Avatar
    Join Date
    Sep 2011
    Location
    Omaha, Nebraska
    Posts
    448
    +1
    32
    Yeah I just checked the SC again from a better angle and it spins both ways, just couldnt get enough of a grip from my original angle. I guess I'm upgrading sooner than I hoped..

  5. #5
    Whats that whistling noise? jtskier11's Avatar
    Join Date
    Sep 2007
    Location
    Right side of Kansas
    Posts
    4,342
    +1
    87
    Quote Originally Posted by Carbonic View Post
    Yeah I just checked the SC again from a better angle and it spins both ways, just couldnt get enough of a grip from my original angle. I guess I'm upgrading sooner than I hoped..
    Sounds like the clutch my friend. Im swapping clutches tuesday night!

  6. #6
    Vanyel1970's Avatar
    Join Date
    Aug 2011
    Location
    Atlanta, Georgia
    Posts
    105
    Damn Carb man sorry bout all that. No fun at all BOOOOO!

  7. #7

    Join Date
    Mar 2010
    Location
    the moon
    Posts
    862
    +1
    19
    if you can afford it get the 2011 and the riva gear dampener at the same time it would be a very wise investment.

  8. #8
    Whats that whistling noise? jtskier11's Avatar
    Join Date
    Sep 2007
    Location
    Right side of Kansas
    Posts
    4,342
    +1
    87
    Fix the clutch yet?

  9. #9
    Carbonic's Avatar
    Join Date
    Sep 2011
    Location
    Omaha, Nebraska
    Posts
    448
    +1
    32
    I took it to the dealer so they can fix it under warranty and they're pretty busy so they wont get around to it until monday. I figure after I get it back I'll upgrade some stuff in hopes of limiting the issues. Next time I'm on my own with this one since my warranty will be up, it happened at just the right time I guess. I thought originally that my warranty was up but I have it for a wee bit longer so thats good.

  10. #10
    Whats that whistling noise? jtskier11's Avatar
    Join Date
    Sep 2007
    Location
    Right side of Kansas
    Posts
    4,342
    +1
    87
    Quote Originally Posted by Carbonic View Post
    I took it to the dealer so they can fix it under warranty and they're pretty busy so they wont get around to it until monday. I figure after I get it back I'll upgrade some stuff in hopes of limiting the issues. Next time I'm on my own with this one since my warranty will be up, it happened at just the right time I guess. I thought originally that my warranty was up but I have it for a wee bit longer so thats good.
    Thats good. I finished mine up last night. Im ready to see how she acts. Are you still running the stock SC wheel?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. great day at the lake
    By big raider in forum Yamaha Old School Skis
    Replies: 211
    Last Post: 11-06-2007, 07:47 PM
  2. Best day at the lake ever!!!!!!
    By gtxscrider in forum 4-Tec Performance
    Replies: 29
    Last Post: 10-11-2007, 06:02 PM
  3. not so great day at the lake
    By addicted in forum Yamaha Old School Skis
    Replies: 30
    Last Post: 10-09-2007, 10:10 PM
  4. Not too bad of a day at the lake......
    By camar0 in forum 4-Tec Performance
    Replies: 1
    Last Post: 04-23-2007, 11:28 AM
  5. Bad Day At The Lake....:(
    By dereksabolracing in forum 4-Tec Performance
    Replies: 2
    Last Post: 08-08-2005, 08:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •