Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13

Thread: rev limiter?

  1. #1

    Join Date
    Jul 2010
    Location
    Mt carroll, IL
    Posts
    91

    rev limiter?

    I have a 1996 SL 900 and i took it out yesterday it ran great for a while but now it wont rev all the way up it seems like its hitting a rev limiter. So i loaded them up and came in. I started it on the trailer and it would just bog if i tried to rev it up. What could cause this?


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Low fuel or Low oil warnings on the MFD display?

    Red flashing light?

    Original or Updated ignition system?

  3. #3

    Join Date
    Jul 2010
    Location
    Mt carroll, IL
    Posts
    91
    Quote Originally Posted by K447 View Post
    Low fuel or Low oil warnings on the MFD display?

    Red flashing light?

    Original or Updated ignition system?
    MFD doesnt work and it has the updated ignition system

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Is the bad MFD still plugged in? Sometimes a non functioning MFD can mess up the ignition.

    Of course, without an MFD it is hard to know if a real problem is happening.

  5. #5

    Join Date
    Jul 2010
    Location
    Mt carroll, IL
    Posts
    91
    Quote Originally Posted by K447 View Post
    Is the bad MFD still plugged in? Sometimes a non functioning MFD can mess up the ignition.

    Of course, without an MFD it is hard to know if a real problem is happening.
    I unplugged the mfd and it still ran the same. When its outta the water it seems to smoke a lot more than normal. I plugged the MFD back in and it worked for a bit but i didn't see any warning messages/lights. I tried to do a compression tester but evidently my tester is broke and ill have to borrow one tom.

  6. #6
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    I had the module for the rev limiter go bad in mine. Sometimes it would limit the RPM and sometimes it would run fine. Since I have a working MFD, I saw no need for the limiter and just disconnected the grey wire from the CDI. The MFD will warn me of any issues I might have.

  7. #7
    I had a bad mfd on my 780. It wiped out the 1/4 amp fuse and would throw it into safe mode (rev limiter) randomly. Fuse is located in the electrical box. I also had to disconnect the mfd to keep the fuse from blowing. If you are patient enough, you can get mfd's pretty cheap on ebay. I got one for $40 shipped

  8. #8

    Join Date
    Jul 2010
    Location
    Mt carroll, IL
    Posts
    91
    finally got a chance to work on it and pulled out that fuse and it looked fine. I unpluged the gray wire but then it wouldnt start. (Had no spark) so i plugged the gray wire back in and it started and ran fine. Also the MFD seems to be working fine now? Why is this and what do you guys think my problem was?

  9. #9
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276

    RPM Limiter - which gray wire is not the right gray wire

    There can be two different gray wires. One connects directly between the CDI and stator, which must be in place for the engine to run.

    As I recall, the genuine rev limiter wire (which we commonly refer to as THE gray wire) is sometimes actually a Tan color (Light Brown) on some older CDI.

    And some CDI do not have a rev limiter wire at all, although I have forgotten which models that applies to.

  10. #10

    Join Date
    Jul 2010
    Location
    Mt carroll, IL
    Posts
    91
    Well spoke to soon because it worked for a bit today then started doing it sporadically. And now does it most of the time and just randomly works sometimes. So which wire do i need to unplug?

    On a side note the MFD still seems to be working fine.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RPM - Rev Limiter - Mods...
    By majundecid in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-10-2006, 04:31 PM
  2. RPMs specs say rev limiter @ 8000?
    By meirvin in forum 4-Tec Performance
    Replies: 12
    Last Post: 03-07-2006, 12:32 PM
  3. Stock Rev Limiter Question
    By Sirhc7897 in forum 4-Tec Performance
    Replies: 6
    Last Post: 02-03-2006, 07:26 PM
  4. Did I hit the rev limiter or a fish?
    By Mark S in forum 4-Tec Performance
    Replies: 1
    Last Post: 09-03-2005, 10:48 PM
  5. Bouncing off the rev limiter, Yay or Nay
    By Gforce in forum 4-Tec Performance
    Replies: 11
    Last Post: 05-29-2005, 01:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •