Results 1 to 6 of 6
  1. #1

    Boost question 300x

    Hey guys. I installed an autometer boost guage on ski. Last weekend it was giving me a consistent reading of 17 psi with spikes in chop and stock dash guage was reading about 14psi. This weekend it was extremely choppy and I noticed my autometer boost guage was reading 15 psi and was twitching bigtime between 14-16 psi. Even when I hit some glassy areas in a cove it was still twitching. It never did that before. Ski felt fine but was just wondering if maybe due to how choppy it was I need to reinspect my line connection for the autometer as I dont recall whether on a car, jetski or whatever a boost guage twitching so bad at wot. Suggestions? Thanks.
    Mods are.....
    R&D scom
    block off
    exhaust filter removed
    Riva waterbx
    Riva freeflow
    R&D rideplate
    ppk
    Solas 14/21
    Ski has 5 hours.


  2. #2
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    Your boost is normal

  3. #3
    Even with the first day the autometer reading 17psi? Ski feels fine but was just confused cause of the twitching. Thanks.

  4. #4
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129

  5. #5
    Thanks bro

  6. #6
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    its twitching because its not a liquid filled gauge

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. quick supercharger boost question
    By Jessie00721 in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 08-02-2011, 12:30 AM
  2. modding 07 pump shaft info/ compared to 2011 parts.few questions 300x parts are in.
    By 98gsxl951 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 52
    Last Post: 05-11-2011, 11:15 AM
  3. Boost question
    By outonalimb in forum 4-Tec Performance
    Replies: 3
    Last Post: 09-01-2010, 09:56 PM
  4. Simple boost questions for R-12X. Max and "limp mode"
    By obiwan in forum Honda Open Discussion
    Replies: 8
    Last Post: 06-25-2009, 08:08 PM
  5. Boost questions for Jerry..........
    By SKR8PN in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-18-2005, 08:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •