Results 1 to 3 of 3
  1. #1

    96 polaris sl 900

    i've got a 96 sl 900 good compression,cranks & idles fine.revs to 7500 on the trailer but when you put it in the water it only revs to 2500 and runs about 10mph.clearances are .006 on the impeller.any ideas guys?


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Have the carbs been cleaned/rebuilt? Does it have the ignition update kit installed?

  3. #3
    carbs cleaned, no ignition update,wear ring clearences look good.found a tan wire cominng out of the cdi box.where does it go?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 Polaris SL 900 carb issues?
    By darrin5 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-31-2015, 11:28 PM
  2. looking to buy a 96 polaris SL 900 Hull with Texas title
    By SL900TX in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-28-2014, 01:24 PM
  3. 96 Polaris SL 900 Reviews please.
    By rlalani in forum Polaris Projects
    Replies: 29
    Last Post: 06-18-2013, 03:21 PM
  4. polaris sl 1050 polaris sl 900 for sale
    By keith neff in forum Polaris Skis
    Replies: 0
    Last Post: 08-03-2008, 06:57 AM
  5. WTB: 94-95-96 Polaris SL Series Ski with a 750 engine
    By Feral in forum Polaris Classifieds
    Replies: 0
    Last Post: 06-16-2008, 10:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •