Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1

    Oil Pump working or not, how to test?

    I dont think I am getting the proper mixure of oil and gas to my engine. How can I even test to see if I am or not?

    I think I am just going to block off the oiul pump. Any advise on this would be greatly appreciated.
    I plan to make my own but at $15 it might be work just buying one.

    Oil to gas ratio would help too if anyone knows

    2000 Polaris SLX 1200


  2. #2
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by heebeha View Post
    I dont think I am getting the proper mixure of oil and gas to my engine. How can I even test to see if I am or not?

    I think I am just going to block off the oiul pump. Any advise on this would be greatly appreciated.
    I plan to make my own but at $15 it might be work just buying one.

    Oil to gas ratio would help too if anyone knows

    2000 Polaris SLX 1200
    Buy the kit. Use silicone to ensure it seals. Make sure you remove the pump gear with a pair of needle nose pliers as well. 40:1 for most oils seems to be the norm.

  3. #3
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    There is no pump gear in a domestic motor. You can check the oil pump by pulling a line off for a few seconds with the engine running. See if there is oil coming out. The pumps are very reliable. No reason to block it off. As long as the cable for the pump is adjusted properly, and all of the lines and filter are good, there is no issue with using the oil injection. In fact, you use a lot less oil with the oil injection system installed. What makes you think you aren't getting enough oil?

  4. #4
    Piston #1 blew up. Hole in it. It fried no oil was present. Maybe a clogged line. I alrady made the block off plate. I really want to be safer than sorry. This ski has caused me a lot of pain and money.

  5. #5

  6. #6
    What else would/could cause the piston to explode like that?

    I jsut want o make sure I am chasing the correct culprit. I think it is lack of oil.

  7. #7
    David Drkvampire2001's Avatar
    Join Date
    Jul 2011
    Location
    Edgerton, Wisconsin, United States
    Posts
    2,857
    +1
    30
    the scoring all over the sides looks exactly like my SLT did when i blew up a piston, oil line had actually fallen off and me being in a hurry to ride never checked it, the oil system as bryan said is VERY reliable. no reason to block it off, replace all the lines from the oil pump to the intake fill them with oil and you should be FINE

  8. #8
    It doesnt look like I am getting oil to the carbs after I rebuilt the engine. How long does it take for the oil to get to the carbs after the oil pump is drained and all new lines are put on? I bled it already and still no oil coming out of the pump throught the lines. Should I remove all the lines to the carbs to get a flow of oil? I pre-mixed some oil inot the gas just to be safe and sprayed fogging oil in the carbs. I am not comfortable taking her out until I see oil hit those carbs. I dont want to replace another piston.

  9. #9
    urugol's Avatar
    Join Date
    Nov 2009
    Location
    Sydney, Australia
    Posts
    1,231
    +1
    3
    Mine took up to 2 minutes on the hose after a considerable bleed of the pump. Allow the engine to stay at idle and manually operate the pump throttle by hand to keep it open until you see the droplets get pushed out.

  10. #10
    Ill try that, thanks.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fuel Pump Working or Not?
    By xplimited in forum 2-Stroke Performance
    Replies: 4
    Last Post: 10-08-2014, 05:25 PM
  2. How do I check to see if oil pump working or not?
    By Seakid in forum Polaris How To & FAQs
    Replies: 7
    Last Post: 02-04-2013, 06:22 PM
  3. Oil pump shaft, or not?
    By LPG256 in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 05-16-2009, 10:46 PM
  4. How to tell if the VTS is working or not?
    By rxpx2008 in forum 2-Stroke Performance
    Replies: 6
    Last Post: 05-04-2008, 08:59 PM
  5. Oil Pump Remove or Not
    By beerdart in forum Yamaha PWC Performance (2-stroke)
    Replies: 15
    Last Post: 08-19-2007, 01:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •