Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 26
  1. #1

    Join Date
    Sep 2011
    Location
    Toms River, New Jersey, United States
    Posts
    26

    08 sho problems !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    ok well here goes nothing cant figure out the problem maybe someone can help
    mods
    r2 reflash
    e1 wheel
    billet super charger shaft
    hks blow off valve
    engine breather
    Pro Comp Cool Air Filter Kit
    R&D Yamaha SHO/FZR Forged Racing Piston 8-6.1
    riva rear exhaust kit
    3 bar map sensor
    fuel pressure regulator kit
    power shot tuner



    the fun all started my firts ride of the yr took it out let it warm up and boom smoke was comming out of the breather took it home did a compression test and found #1 15ps1 #2 0 psi #3 90 ps1 #4 90 psi took motor out and found rings and pistons looked like pic below replace all 4 sets of rings and pistons put everything back togeather and checked compression all over 90 psi idles bad but adjuest fuel pressure not it idles but not that good took it out on water and ran good for a half hr but was way rich 14.5 on afg then all of sudden soungs like a plug fauled out took it home again and did compression test and found #2 again 45 psi and will not idle at all y would the same cylinder get messed up again im out of ideas im gonna pull the head again today and check the valves and head gasket any ideas will be a big help my yamaha dealler told me to go f off they r too busy and have no room in their yard but when i went there yesterday to get plugs there was not one ski in the yard



    thanks alot
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMAG0331.jpg 
Views:	93 
Size:	66.0 KB 
ID:	273736   Click image for larger version. 

Name:	IMAG0332.jpg 
Views:	79 
Size:	88.2 KB 
ID:	273737  


  2. #2
    gordon lasiter #328's Avatar
    Join Date
    Aug 2008
    Location
    katy, texas , United States
    Posts
    1,647
    +1
    28
    An afr of 14.5 is lean not rich unless i read it wrong!

  3. #3

    Join Date
    Sep 2011
    Location
    Toms River, New Jersey, United States
    Posts
    26
    plugs are black

  4. #4
    YAMAHA POWAAAA !!!!! 1_Fast_SHO's Avatar
    Join Date
    Apr 2010
    Location
    Houston, Texas
    Posts
    3,143
    +1
    255
    if you ran the ski for an hour and half at 14.5, as far as i know thats way to lean,,,,,dont quote me

  5. #5

    Join Date
    Sep 2011
    Location
    Toms River, New Jersey, United States
    Posts
    26
    Quote Originally Posted by 1_Fast_SHO View Post
    if you ran the ski for an hour and half at 14.5, as far as i know thats way to lean,,,,,dont quote me
    no ur right im wrong plugs are black because when it idles ( thats a big when cuz it wont now ) there is no load on motor

  6. #6
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    14.5 is way too lean 12.1 is perfect.

  7. #7

    Join Date
    Sep 2011
    Location
    Toms River, New Jersey, United States
    Posts
    26
    Quote Originally Posted by JIM'S PERFORMANCE View Post
    14.5 is way too lean 12.1 is perfect.



    Do I need bigger injectors ? Fuel pressure is set to 40 with rising rate on as per r and d. Or is it a ecm reflash problem

  8. #8
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    Quote Originally Posted by fast08fxsho View Post
    Do I need bigger injectors ? Fuel pressure is set to 40 with rising rate on as per r and d. Or is it a ecm reflash problem
    fuel pressure should be set at 50 to 55 with rising rate hooked up with a E1 set up.

  9. #9

    Join Date
    Sep 2011
    Location
    Toms River, New Jersey, United States
    Posts
    26
    wow guess i should learn how to read thanks alot guys

  10. #10
    YAMAHA POWAAAA !!!!! 1_Fast_SHO's Avatar
    Join Date
    Apr 2010
    Location
    Houston, Texas
    Posts
    3,143
    +1
    255
    Quote Originally Posted by JIM'S PERFORMANCE View Post
    14.5 is way too lean 12.1 is perfect.
    exaclty what i thought

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. sho 08 running problems
    By zko in forum Yamaha PWC Performance (4-stroke)
    Replies: 9
    Last Post: 03-26-2012, 01:37 PM
  2. 08 SHO Cruiser starting problem on water
    By Toobold in forum Yamaha PWC Performance (4-stroke)
    Replies: 13
    Last Post: 06-16-2009, 05:40 AM
  3. '08 FX HO vs. '08 SHO
    By jwafer21 in forum Yamaha PWC Performance (4-stroke)
    Replies: 14
    Last Post: 03-03-2008, 12:30 AM
  4. 08 SHO-vibration??
    By Kaybat in forum Yamaha PWC Performance (4-stroke)
    Replies: 11
    Last Post: 02-08-2008, 03:31 AM
  5. 08 sho / 08 sea doo 255
    By steven1300r in forum Yamaha Open Discussion
    Replies: 27
    Last Post: 02-02-2008, 11:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •