Results 1 to 2 of 2
  1. #1

    Join Date
    Jul 2011
    Location
    STL/ST Charles
    Posts
    17

    94 sl 750 stator

    I have a 94 sl750 that had a bad stator in it. When I got to the stator it was covered in oil. Iwas wondering if the stator should be drenched in oil or if I have a seal going bad and that is the reson the stator failed. Any help would be appreciated... thanks


  2. #2
    I'm addicted to Polaris PWC ghostinstallations's Avatar
    Join Date
    Aug 2011
    Location
    Rochester, New York
    Posts
    920
    +1
    28
    It should not be covered in oil. Either the seals are failing or someone poured oil in the stator inspection hole.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 94 sl 750 - bad stator?
    By vmdano in forum Polaris How To & FAQs
    Replies: 7
    Last Post: 07-02-2010, 06:39 PM
  2. '94 SL 750 Fuel Problem
    By rob2337 in forum Polaris Open Discussion
    Replies: 13
    Last Post: 06-24-2007, 07:10 PM
  3. 94 SL 750 and 97 SLT780
    By quad2water in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-19-2007, 12:41 AM
  4. 94 SL 750 just purchased what should i check?
    By GameDemon in forum Polaris Open Discussion
    Replies: 5
    Last Post: 06-19-2007, 12:01 AM
  5. 94 sl 750 maintenance anyone?
    By ducatifreak152 in forum Polaris PWC Performance
    Replies: 4
    Last Post: 06-09-2007, 03:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •