Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1

    Low RMPS, Top speed 40mph, Funny Sound PLEASE HELP!

    Hello,

    Just took out my RXP 215, 2007 and had new plugs installed, an oil change and a new filter.
    Anyway, riding it today it felt extremely weird.
    About 90+ hours on the ski so I figured its the supercharger.
    The supercharger roter, is not spinning so i figure its not skipping or slipping.
    The ski will not go over 40,42 mph, and rpms only reach about 5k.
    There is no kick (burst of speed) which i had last year and the engine sounds funny.

    I'm thinking:
    fuel pump?
    possibly supercharger?

    If anyone can please advice that would be great.


  2. #2
    Electronics Guru Alpheus's Avatar
    Join Date
    Aug 2010
    Location
    Lake Anna Va
    Posts
    520
    +1
    1
    Sounds like the ceramic washers in your super charger just took a shit. Probably just ruined your engine... Welcome aboard...

  3. #3
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    I believe 06 was the last year for those

  4. #4
    ADAMBOMB's Avatar
    Join Date
    Mar 2006
    Location
    Sunrise,Florida
    Posts
    4,723
    +1
    196
    Ive had metal washers take a shit... Pull your supercharger hose and try spinning them wheel by hand... report back. welcome to the forum.

  5. #5
    Hello,

    I pulled the hose out. The supercharger roter is NOT moving. It is stiff.

    I am thinking perhaps its the fuel pump. I have 93 hours so i figure its time to change the supercharger anyway.

    Thanks

  6. #6
    idoodou's Avatar
    Join Date
    Mar 2009
    Location
    cincy,ohio
    Posts
    765
    +1
    30
    now that we now that the supercharger wheel is not slipping , my guess is even though you had new plugs install one of them is bad , throw in another flesh set of plugs welcome to greenhulk

  7. #7
    Thanks, you really think it might be a plug? It does sound like 2 of the cylinders don't power up. Can it be that the gas is old? Or perhaps there isn't enough pressure (gas pump not working properlly)

  8. #8
    Roll Tide!! SeadooTech's Avatar
    Join Date
    Jun 2011
    Location
    Birmingham, AL
    Posts
    662
    +1
    18
    yeah put a new set of plugs in, cheapest idea to start... see how the ski revs out of the water but don't run it long unless you hook up the hose pipe to the adapter

  9. #9
    Quote Originally Posted by SeadooTech View Post
    yeah put a new set of plugs in, cheapest idea to start... see how the ski revs out of the water but don't run it long unless you hook up the hose pipe to the adapter
    It runs like S**T. No pull at all.
    I will go see if there are any holes in the hose and if the supercharger hose kicks when i rev the engine.
    Also out of the water if i notice that the rpms do go up does that mean anything?

  10. #10
    Electronics Guru Alpheus's Avatar
    Join Date
    Aug 2010
    Location
    Lake Anna Va
    Posts
    520
    +1
    1
    Check and make sure you don't have a t-shirt wrapped around your prop. I just had this happen to me last week. I love how people use the ocean as a garbage can...

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. top speed only 68mph need some help to go faster
    By LI JETSKIER53190 in forum Yamaha PWC Performance (4-stroke)
    Replies: 60
    Last Post: 10-14-2015, 08:07 PM
  2. Replies: 46
    Last Post: 08-17-2013, 08:30 PM
  3. 1999 Ultra 150 only doing 4000rpm 40mph on water. Please help.
    By cjelley in forum Kawasaki Open Discussion
    Replies: 13
    Last Post: 07-31-2012, 08:20 PM
  4. My 1996 SLT 780 won't start, just clicking sound please help!!
    By smitty564 in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 07-28-2011, 08:35 AM
  5. Top Speed 40mph...? Please Help
    By mirzar1 in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-16-2008, 09:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •