Results 1 to 5 of 5
  1. #1

    Join Date
    Jun 2012
    Location
    Birmingham, Alabama, United States
    Posts
    7

    Another day....another problem....

    So I have a 2002 Virage that I inherited more or less and seem to spend much more $ on it each year than I ever thought possible. Has been in shop much more than on water over the last few years and a few months ago I lost my job and no extra $ to put down on shop work. Am a decent mechanic although this Polaris is not my sons XR80 sitting on the table....so wondering if anyone might help with a diagnosis this time around just from hearing it run, so I made a video and posted it to Youtube. Basically, starts sluggishly then builds to about half throttle before beginning to "surge" from that point on. More than half throttle produces bog down. Have run a new tank of good gas through it and cleaned plugs but no change. Any help would be appreciated, just would like to try to fix myself before turning over to big bucks shop and not see it most of the summer....thanks in advance.



  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Have you ever cleaned/ rebuilt the carb? Does the ski have grey fuel lines on it. Now that I hear it run, it sounds like a rev limiter. Possible electrical problem.

  3. #3
    ripcuda's Avatar
    Join Date
    May 2010
    Location
    Newman Lake, WA
    Posts
    2,389
    +1
    166
    Welcome to Green Hulk.

    Tons of info and many helpful folks here on the forum. Best place to start your Polaris PWC education is here:
    http://polarispwcknowledge.shorturl.com/

    Cheers!

  4. #4

    Join Date
    Jun 2012
    Location
    Birmingham, Alabama, United States
    Posts
    7
    Yes fuel lines are gray. Have not touched carbs, again somewhat new to me to be able to look under hood. Originally, I was told it was fuel injected, is it not? I see lots of views of the video link i posted, but not many guesses as to a remedy, is that a sign, an omen perhaps!! Thanks again in advance for looking....


  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,276
    Quote Originally Posted by david.neal1 View Post
    Yes fuel lines are gray. Have not touched carbs, again somewhat new to me to be able to look under hood. Originally, I was told it was fuel injected, is it not? ...
    Absolutely not fuel injected!

    It is NOT a good idea to keep riding and 'pushing' the engine for many minutes at a time until you have all the problems properly diagnosed and fixed. It is easy to burn down a piston from lean fuel conditions.

    I see original fuel lines, poorly running engine. That suggests it is way overdue for a carb rebuild and fuel system refresh. Replace all those fuel lines and get the carbs into shape.

    Also check compression and ignition system. Fresh spark plugs of the correct type. Check every hose clamp and hose for problems, worn spots, cracking, looseness.

    THEN go for a _short_ test ride.

    These high output 2-stroke engines require the fuel system to be 100% good. Otherwise you risk severe engine damage, and it can happen in minutes.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 99 xl1200ltd - another problem -arrrggghhh
    By sunshine_n_pc in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 09-23-2008, 04:39 PM
  2. Another Problem, Loss of Power, Stuttering at top Speed
    By ercBOOSTED in forum Kawasaki PWC Performance (4-stroke)
    Replies: 10
    Last Post: 06-29-2008, 05:31 PM
  3. Ha Ha Ha! Another Problem On My 01 Gp1200r!!
    By YOUNGGUNZ403 in forum Yamaha PWC Performance (2-stroke)
    Replies: 23
    Last Post: 06-26-2008, 03:16 PM
  4. Yet another problem!!!! pump removal from hull question
    By spyder3000gtvr4 in forum Yamaha Open Discussion
    Replies: 14
    Last Post: 09-20-2007, 03:07 PM
  5. Another Problem
    By whiteyz in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 08-06-2007, 02:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •