Results 1 to 6 of 6
  1. #1
    macdoo's Avatar
    Join Date
    May 2010
    Location
    Acworth, Ga
    Posts
    264
    +1
    1

    2001 Virage TXi TPS may not be bad so what then?

    My 2001 Virage TXi was slowing down after driving it all day it would not go past 40 mph. I had it up to 59 mph. I thought it was the TPS so I ordered one and got it in today. I hooked a meter up to the new one and it read 1...2...3...4..5..6..7..8 as I moved the lever. Just for kicks I hooked up the old one and 1...2...3...4..5..6..7..8 as I moved the lever....crap did I just pay $84 for a part I did not need. I did hook the meter to it befor I took it out but now I think I could have had it on the wrong setting....sure I had it on the wrong one. Question over a day of riding could it just get bad? It seem like it always runs great when I first take it out. Idon't dog it 25 mph is cool with me all day long then the 58 mph is funner...LOL. What else could it be.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Install the new TPS and run it.

    TPS cannot be bench tested to prove 'good'.

    Vibration and heat can cause a TPS to fail on the engine but appear to 'work' on the bench.

  3. #3
    macdoo's Avatar
    Join Date
    May 2010
    Location
    Acworth, Ga
    Posts
    264
    +1
    1
    Ok thanks I will install it and see if I still have the problem. Would it be good to hook up a fuel pressure gauge and see if the the pressure is dropping and that is why it is slowing down? The gas was 3/4 ful but the oil was 1/2 to 1/4 full would that make it slow down? Seem like a read that it will only do 3500 rpms what they get low.

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Quote Originally Posted by macdoo View Post
    ... Would it be good to hook up a fuel pressure gauge and see if the the pressure is dropping and that is why it is slowing down? The gas was 3/4 ful but the oil was 1/2 to 1/4 full would that make it slow down? Seem like a read that it will only do 3500 rpms what they get low.
    Be careful not to confuse the carb engines with the Fuel injected machines. They have differences

    No warnings on the display for Low Oil or Low Fuel? Then no issues there.

    See the Ficht section of my signature links for more info about what can cause low RPM on a Ficht engine.

    It is possible for the electric fuel pump to weaken and not deliver the normal 20+ PSI. Just be VERY careful about riding with a fuel pressure gauge connected to the fuel return tee nipple. A fuel leak inside the hull is a bad thing.

    If fuel pressure is very low then it is likely that the pressure regulator has fallen off inside the fuel tank. Repair info via my signature links.

  5. #5
    macdoo's Avatar
    Join Date
    May 2010
    Location
    Acworth, Ga
    Posts
    264
    +1
    1
    I will check the presure out of the water if it is low then the inline regulator seems the way to go. Again it seems to run most of the day great it's just near the end oof riding it will not egt up to the higher speed. I will also check the compression again to make sure that is all good.

  6. #6
    macdoo's Avatar
    Join Date
    May 2010
    Location
    Acworth, Ga
    Posts
    264
    +1
    1
    I just tried to put the "NEW" TPS in my 2001 TXi. I thought I had it on right but when I started it the idle was to high. I tried to center it the best I could. Any tip on how to install it?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 Virage TXI FICHT loud backfires when trying to start, will not start
    By terrygilomen in forum Polaris Open Discussion
    Replies: 11
    Last Post: 08-12-2016, 07:44 AM
  2. Replies: 19
    Last Post: 11-19-2014, 10:03 AM
  3. TPS for a 2001 Virage TXI
    By jsmiech in forum Polaris Open Discussion
    Replies: 2
    Last Post: 01-01-2012, 03:10 PM
  4. Polaris 2001 Virage TXI 1200 idles great will not go over idle
    By jsmiech in forum Polaris Open Discussion
    Replies: 5
    Last Post: 01-01-2012, 01:00 PM
  5. 2001 VIRAGE TXI- running lean
    By SMOKEWAGON in forum Polaris Open Discussion
    Replies: 9
    Last Post: 07-05-2007, 08:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •