Results 1 to 6 of 6
  1. #1
    Matrix 4-Tec spannerspencer's Avatar
    Join Date
    Nov 2010
    Location
    south west England
    Posts
    1,143
    +1
    38

    polaris sl1050 (engine sparks as soon as i let off start button only)

    when cranking the engine there is no spark, but as soon as i let off the start button it sparks and starts is this right???? i also get a bogging down issue, as it's the only thing i can find wrong with the ski,

    hope you can help guy. im sure you can. buckets of knowledge on here.


  2. #2
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,523
    +1
    1,270
    Quote Originally Posted by spannerspencer View Post
    when cranking the engine there is no spark, but as soon as i let off the start button it sparks and starts is this right???? i also get a bogging down issue, as it's the only thing i can find wrong with the ski,

    hope you can help guy. im sure you can. buckets of knowledge on here.
    a little more searching would have turned this up:

    https://sites.google.com/site/polari...ition-system-1

  3. #3
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    weak battery

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,589
    +1
    1,272
    Quote Originally Posted by nmpeter View Post
    a little more searching would have turned this up:

    https://sites.google.com/site/polari...ition-system-1
    Thanks

    I suppose the spark when releasing the Start button symptom might be more strongly linked to indicating a weak battery.

  5. #5
    Matrix 4-Tec spannerspencer's Avatar
    Join Date
    Nov 2010
    Location
    south west England
    Posts
    1,143
    +1
    38
    Thank you guys.! super rapid response.!!!!

    BryanP hows your pro1200?? im still looking wide eye'd for a good one in England.

  6. #6
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Pro is running awesome!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 42
    Last Post: 08-10-2015, 02:42 PM
  2. Replies: 2
    Last Post: 07-14-2011, 04:31 PM
  3. Replies: 4
    Last Post: 06-16-2011, 02:21 PM
  4. just purchased a 03 gp800r need some schooling as well as help let me start from the
    By 98gsxl951 in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 01-21-2010, 03:08 PM
  5. Spark just as I let go of start switch
    By retro in forum Polaris Open Discussion
    Replies: 24
    Last Post: 07-23-2009, 09:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •