Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25
  1. #1

    Join Date
    Apr 2012
    Location
    Port Clinton, Ohio, United States
    Posts
    44
    +1
    2

    Can I use a 95 SL650 pump in a 93 SL750?

    Hi Guys,
    Last week I picked up my first two Polaris skis. The 95 is for parts only. It ran lean and burned a piston. Most of the mechanical stuff looks ok for parts but the hull was trashed. However, the 93 looks decent. The guy I got them from said that the '93 wouldn't start. It would backfire. I had all kind of thoughts about a bad CDI, stator, bent crank or who knows what else. Today I decided to try to start it. It fired right up but the pump was making a horrible racket. I pulled the pump and the bearings are toast. With the pump out, it started it again and the motor sounds fine.
    So, I have the pump out of the '95 SL650 that looks like it is in decent shape. Can I use that on the '93 SL750?

    Thanks,

    Jeff
    Last edited by Jeffery73; 06-12-2012 at 09:27 PM.


  2. #2
    RLACEMAN's Avatar
    Join Date
    Aug 2011
    Location
    Random Lake WI
    Posts
    884
    +1
    54
    No, they are different, the '94 & up are the same, 92-93 are the same, all different parts & different pump diameters.

  3. #3
    David Drkvampire2001's Avatar
    Join Date
    Jul 2011
    Location
    Edgerton, Wisconsin, United States
    Posts
    2,857
    +1
    30
    Quote Originally Posted by Jeffery73 View Post
    Hi Guys,
    Last week I picked up my first two Polaris skis. The 95 is for parts only. It ran lean and burned a piston. Most of the mechanical stuff looks ok for parts but the hull was trashed. However, the 93 looks decent. The guy I got them from said that the '93 wouldn't start. It would backfire. I had all kind of thoughts about a bad CDI, stator, bent crank or who knows what else. Today I decided to try to start it. It fired right up but the pump was making a horrible racket. I pulled the pump and the bearings are toast. With the pump out, it started it again and the motor sounds fine.
    So, I have the pump out of the '95 SL560 that looks like it is in decent shape. Can I use that on the '93 SL750?

    Thanks,

    Jeff
    Why don't you pull the engine out of the 93 and put it in the 95?

  4. #4

    Join Date
    Apr 2012
    Location
    Port Clinton, Ohio, United States
    Posts
    44
    +1
    2
    The '95 Hull is trashed. Someone spray painted it white and red. It's already completely stripped and ready to go to the dump.

    Well, if someone would be willing to trade my '95 pump for a '93, let me know.

    Thanks for the info.

    Jeff

  5. #5

    Join Date
    Jun 2012
    Location
    Swartz Creek Michigan
    Posts
    77
    I have a complete 93 SL 750 in mid michigan. come take the entire ski for $150. Just needs one piston. Pump is good.....heck the hull is in better shape than my 95 also.
    You are 2-1/2 hours from me.

  6. #6
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    You can use the pump from the 95 on the 93. In fact you should do this. You just have to replace all of it from the wear ring on the hull back. You cannot mix and match parts from the 2 pumps. Putting the 95 pump will yield better performance. Just make sure you are running an impeller on the 95 pump thats appropriate for a 750. A 5131079 is whats stock on a 94 or 95 750. Should be easy to find one of those.

  7. #7
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Quote Originally Posted by BryanP View Post
    You can use the pump from the 95 on the 93. In fact you should do this. You just have to replace all of it from the wear ring on the hull back. You cannot mix and match parts from the 2 pumps. Putting the 95 pump will yield better performance. Just make sure you are running an impeller on the 95 pump thats appropriate for a 750. A 5131079 is whats stock on a 94 or 95 750. Should be easy to find one of those.
    Absoultely ^^^^

  8. #8

    Join Date
    Apr 2012
    Location
    Port Clinton, Ohio, United States
    Posts
    44
    +1
    2
    So I need to use the black (plastic I think) ring off of the hull of the '95 that the pump mates up to?

  9. #9
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Quote Originally Posted by Jeffery73 View Post
    So I need to use the black (plastic I think) ring off of the hull of the '95 that the pump mates up to?
    Yes. Its aluminum by the way. Bolt the pump base to the hull and seal it with silicone.

  10. #10

    Join Date
    Apr 2012
    Location
    Port Clinton, Ohio, United States
    Posts
    44
    +1
    2
    Thank You. I will give it a shot.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How do I prime the oil pump in my 95 polaris sl650?
    By Slauber88 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 06-22-2016, 08:46 PM
  2. Replies: 6
    Last Post: 07-31-2009, 08:35 AM
  3. '95 750 engine in a '93 750
    By cubsfan2516 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 04-30-2009, 03:55 AM
  4. Triples What jet in water line? Can I use inserts stingers?
    By philip_gpr in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 07-01-2006, 05:21 PM
  5. Synthetic oil??? which brand can be use in s/c engine?
    By novice_4 in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-15-2006, 01:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •