Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
  1. #1

    ZXI 1100 stalling at high RPM and full throttle

    I have a Kawasaki ZXI 1100 that's having a stalling problem when I'm getting on it hard.

    I took it out to the lake today and it started up just fine. I rode it 2-up with my wife for about an hour, never really getting on it hard, and it had no issues. I dropped her off at the dock and went to go ride it hard, that's when it started having a problem. When I'd be really getting into it, it would stall. It would start right back up and run fine at light or half throttle, only to stall again if I started really getting into it. The heat light never came on and the water coming out the squirter wasn't overly hot or anything, so I'm thinking it's a fuel issue. Does anybody have any advice or experience with a similar problem?


  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    285
    Sounds like carbs and/or fuel filter.

    Have you looked at the plugs? When you do, you might run a compression test, too.

  3. #3
    Plugs were new last year. It starts really easy, so I assumed they weren't the issue. Same with compression, it has good pick up until it starts to stall.

  4. #4
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,530
    +1
    1,281
    fuel for sure. Is there a hulltemp sensor on that model?

  5. #5
    I'm going to try the filter, I'm hoping that I don't have to tear apart the carbs. I've done one before on my bike, but I'm not really interested in messing with three (especially since I'll have to sync them).

  6. #6
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,530
    +1
    1,281
    you won.t need to sync them..as long as you don.t pull them off the rail that is. Only use an oem style filter btw..plastic mesh. Paper filters restrict fuel flow after a while.

  7. #7
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    285
    Quote Originally Posted by atvman View Post
    Plugs were new last year. It starts really easy, so I assumed they weren't the issue. Same with compression, it has good pick up until it starts to stall.
    It doesn't matter that the plugs were new last year, what matters is what they look like. That will verify that it's lean. If it's not lean, the compression would be the next thing to check.

  8. #8
    I'll check them when I get some free time, probably Thurs. Might as well check compression if I'm pulling the plugs, what compression should the cylinders read?

  9. #9
    I put new plugs in it and took it for a test run, same issue. I pulled the plugs and they are coated in oil. The exhaust also seemed particularly smokey. I'm wondering if it's getting oil ok, but not gas.

    I'm going to try to get a compression tester this week.

  10. #10
    to some the plugs arent important, to others that can read em its very important, if someone is trying to help and ask for a picture it should be posted, or interest could be lost.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 9
    Last Post: 05-06-2011, 07:53 AM
  2. '02 ZXI 1100 buy at auction?
    By brax in forum Kawasaki PWC Performance (2-stroke)
    Replies: 4
    Last Post: 05-10-2009, 11:43 AM
  3. 2001 zxi 1100 stalls when you hit the throttle more than 1/2 way from an idle
    By offroadinjersey in forum Kawasaki PWC Performance (2-stroke)
    Replies: 2
    Last Post: 05-10-2009, 11:12 AM
  4. XL1200 cavitation at high RPMs
    By jamie327 in forum Yamaha PWC Performance (2-stroke)
    Replies: 13
    Last Post: 03-19-2009, 07:17 AM
  5. 99 GTX Ltd Cutting out at high RPM
    By Picturemn2 in forum 2-Stroke Performance
    Replies: 8
    Last Post: 09-28-2007, 04:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •