Results 1 to 8 of 8
  1. #1
    mikevv's Avatar
    Join Date
    Feb 2008
    Location
    Lake Erie
    Posts
    149

    Am I running too lean or just right for 11 psi and 8200 RPMs?

    I finally found some smooth water and got a chance to do some speed runs on my winter mods. I am now running R&Ds c3/r3 combination with a Skat 14/23. I have the R&D pro i/c with cooling kit and thermostat removed. And a Greddy BOV set as delivered from R&D. Performance looks like:

    Ambient temperature 85deg
    Max speed is 77.2mph
    Max RPM is 8200
    AFR at full throttle is 12.3 to 12.5
    Max boost is just under 11PSI. Call it 10.8
    See attached picture of boost and AFR gauge. The AFR reads 12.4 but the camera only catches the 2 and 4.

    Click image for larger version. 

Name:	2012-06-09 AFR12-4 Boost10-8.jpg 
Views:	52 
Size:	103.7 KB 
ID:	274149

    The boost seems a little low for 8200RPMs and the AFR seems a bit lean at WOT? I have attached a picture of the plugs. The middle two have always been a little lighter but they are a now lot lighter in color.

    Am I running too lean or just right for 11 psi and 8200 RPMs?


    Click image for larger version. 

Name:	Img_0139Right to Left is Front to Rear.jpg 
Views:	80 
Size:	113.2 KB 
ID:	274148







  2. #2
    hdlefler's Avatar
    Join Date
    Aug 2010
    Location
    Wesley Chapel, Fl
    Posts
    911
    +1
    100
    Quote Originally Posted by mikevv View Post
    I finally found some smooth water and got a chance to do some speed runs on my winter mods. I am now running R&Ds c3/r3 combination with a Skat 14/23. I have the R&D pro i/c with cooling kit and thermostat removed. And a Greddy BOV set as delivered from R&D. Performance looks like:

    Ambient temperature 85deg
    Max speed is 77.2mph
    Max RPM is 8200
    AFR at full throttle is 12.3 to 12.5
    Max boost is just under 11PSI. Call it 10.8
    See attached picture of boost and AFR gauge. The AFR reads 12.4 but the camera only catches the 2 and 4.

    Click image for larger version. 

Name:	2012-06-09 AFR12-4 Boost10-8.jpg 
Views:	52 
Size:	103.7 KB 
ID:	274149

    The boost seems a little low for 8200RPMs and the AFR seems a bit lean at WOT? I have attached a picture of the plugs. The middle two have always been a little lighter but they are a now lot lighter in color.

    Am I running too lean or just right for 11 psi and 8200 RPMs?


    Click image for larger version. 

Name:	Img_0139Right to Left is Front to Rear.jpg 
Views:	80 
Size:	113.2 KB 
ID:	274148






    From what I know you should be at 12.1 so yes your running a little lean and your rpms are way down. You should be turning 8400 - 8600. I would get a RRFPR to adjust your afr's and have your prop repitched.

  3. #3
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    looking at the plugs you are not lean 12.3 to 12.5 is not bad 12.1 is perfect, You need to worry when you get in the 12.8 and up. One thing your rpm's are to low that's why your boost is low.

  4. #4
    Mine goes from 11.8 to 12.3, repitch prop to get RPM's up and should see more boost. Im running a 13/22 now @ 8300 and GPS'ed in low 80's

  5. #5
    mikevv's Avatar
    Join Date
    Feb 2008
    Location
    Lake Erie
    Posts
    149
    Quote Originally Posted by JIM'S PERFORMANCE View Post
    looking at the plugs you are not lean 12.3 to 12.5 is not bad 12.1 is perfect, You need to worry when you get in the 12.8 and up. One thing your rpm's are to low that's why your boost is low.
    Thanks Jim. That's what I had hoped was going on. I wanted to start with lower than optimal RPMs and work my way up.

    So what do plugs look like when they are dangerously lean?

  6. #6

    Join Date
    Jul 2005
    Location
    Central North Carolina
    Posts
    3,847
    +1
    527
    If you click on the sparkplug picture and blow it up you can clearly see that the #2 and #3 sparkplugs are a little bit leaner than #1 and #4 sparkplugs due to the design of the yamaha air intake manifold! Tommy Jordan

  7. #7
    gordon lasiter #328's Avatar
    Join Date
    Aug 2008
    Location
    katy, texas , United States
    Posts
    1,647
    +1
    28
    Do you have a powershot?
    When i had the c3 wheel with a r2 reflash my prop was pitched at 14/23.
    My rpms where 8400 to 8700 depending on my nozzle ring i was using and water/air temps.
    I would be at 78~79 mph constantly.
    In perfect conditions meaning cool air and water i would be at 81 mph.
    I also had the jd intercooler.

  8. #8
    mikevv's Avatar
    Join Date
    Feb 2008
    Location
    Lake Erie
    Posts
    149
    Thanks to everyone for the advice. My next step will be to repitch from 14/23 to 13/22.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 21
    Last Post: 05-21-2016, 08:25 PM
  2. 2011 RXT-X 260 RS runs too lean?
    By HSCOOL in forum 4-Tec Performance
    Replies: 23
    Last Post: 08-08-2013, 10:57 AM
  3. WTB - Parts WTB: 951 engine or just core for 98 XP(Limited) - Sarasota FL
    By chantra in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 10-05-2012, 08:37 AM
  4. Is it possible to run too lean with the factory boost limiter?
    By tsho in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 12-08-2009, 08:22 AM
  5. 05 RXP too lean or too rich
    By inteljd in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 06-17-2008, 09:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •