Results 1 to 5 of 5
  1. #1

    Join Date
    Apr 2012
    Location
    Kansas
    Posts
    3

    GTX Wear Ring or Stick stuck

    Have 04 GTX Supercharged, got a stick stuck in the impeller, pulled from water, and started and blew out stick. Then the motor would not turn over, the starter clicks and I see the impeller turn a 1/4 turn along with the wear ring. Found anther stick and pulled off the bottom plate and pulled out other stick thinking it was jamming the impeller causing it not to turn over. I don't see any more sticks or crap around the impeller but it will not turn over. Looking at the impeller I see white on some of the blades and I am wondering if the wear ring is now up against the impeller and causing it to jam??

    Just as a note I had the supercharger rebuilt this winter but I am not thinking the two are related.

    Has anyone seen this problem??

    Thanks,
    Mark


  2. #2
    04gtxsc's Avatar
    Join Date
    Mar 2006
    Location
    Kansas
    Posts
    3,090
    +1
    197
    Pulle the pump since you are going to have to replace the wear ring anyway. Pull the plugs and see if the motor will turn over. Not sure exactly where to go after that but it will definatley narrow it down. DONT START IT WITH THE PUMP OUT.

  3. #3

    Join Date
    Apr 2012
    Location
    Kansas
    Posts
    3
    I pulled the pump and the motor turns over so I am happy. From the looks of it the wear ring is upagainst the impeller and it frozen in the assembly. The impeller is pretty chewed and there is a ridge on the wear ring. Looks like I need to replace both and possibly the bearings.

    Thank you for your help.

    Mark

  4. #4
    04gtxsc's Avatar
    Join Date
    Mar 2006
    Location
    Kansas
    Posts
    3,090
    +1
    197
    You are good to go replace the impellor and wear ring. Also you might wannt to grease the pump assembly while it is out.

  5. #5

    Join Date
    Apr 2012
    Location
    Kansas
    Posts
    3
    Do you think I need to replace the bearings also, this is an 04 with 93 hours? Are there directions on how to grease the pump, I am new to this thing so I am going at it slow?? It looks like the wear ring warped or out of round and was stuck on the impeller but it is not in good shape either, I just want to make one buy and get her going.

    Thanks for all of your help.

    Mark

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What are the symptoms of an overly worn wear ring? (Or cavitation?)
    By bgaidan in forum Polaris Open Discussion
    Replies: 4
    Last Post: 05-31-2010, 10:13 PM
  2. Wear ring or Extention ring size.
    By bowsniper in forum Polaris PWC Performance
    Replies: 3
    Last Post: 02-01-2010, 01:50 PM
  3. Not the wear ring or impellor.
    By RedRyderRXP in forum 4-Tec Performance
    Replies: 8
    Last Post: 08-10-2006, 06:58 PM
  4. SS wear ring or RR mount
    By Flyer in forum 4-Tec Performance
    Replies: 43
    Last Post: 05-23-2006, 08:23 AM
  5. $50.00 wear ring or $250 impeller?
    By Ed in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 07-06-2005, 03:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •