Results 1 to 5 of 5
  1. #1
    dj Burnout's Avatar
    Join Date
    Jun 2012
    Location
    massachusetts
    Posts
    26

    Question 1998 slth is over charging?????????

    last Sunday, I was ridding it and I look my voltage in the mfd was 16.9 at 5200 rpm. I think that is no normal operation. At 1400 rpm is 14.7 Also the higer reading was 17.3 at 5450 rpm.


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Check it with a voltmeter on the battery while running the motor. If its still reading that high, replace the LR module.

  3. #3
    dj Burnout's Avatar
    Join Date
    Jun 2012
    Location
    massachusetts
    Posts
    26
    thank you BryanP for the info. I just update the ignition system (stator,CDI,coil, spark plugs wires) and in the instructions said to leave the ground wire from the battery to the electric box disconnected. I like to know if the one from the battery or inside the box. The other problem I have with the jetski is bogging down run about 7 -8 mph at 4200 rpm then suddenly pick up and runs about 33-36 mph at 5350 rpm. Let me konw this two problem are related or not.

  4. #4
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    The small black wire that runs from the electric box to the battery is to be removed. That engine should be seeing around 6500-6600 RPM at full throttle.

  5. #5
    dj Burnout's Avatar
    Join Date
    Jun 2012
    Location
    massachusetts
    Posts
    26
    Quote Originally Posted by BryanP View Post
    The small black wire that runs from the electric box to the battery is to be removed. That engine should be seeing around 6500-6600 RPM at full throttle.
    hi bryan .
    when it run only go 5200 to 5600 rpm with throttle and it get into go speed after long period of time the go ok until I stop or I make a sharp turn

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1998 SLTH and SLXH plugs a little over Brown
    By Bobby DeMoss in forum Polaris Open Discussion
    Replies: 0
    Last Post: 08-18-2008, 08:14 PM
  2. 1998 Slth 700 Question ?
    By troyzstang in forum Polaris Open Discussion
    Replies: 8
    Last Post: 10-24-2007, 07:14 PM
  3. Polaris 1998 slhx 1050turns over but no spark?
    By gwestney in forum Polaris Open Discussion
    Replies: 5
    Last Post: 07-17-2007, 11:37 AM
  4. The war is over
    By JRW1484 in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 05-06-2006, 06:05 AM
  5. My RXT Saga is Over
    By Pettee in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 03-20-2006, 11:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •