Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    01 polaris virage oil leak

    Like the title says my 01 virage has a oil leak, I thought it was the cap that sits on top of the oil tank with the small hose that goes through it but nope had it capped and it still leaks.

    I was wondering if there was a schematic or a diagram I could look at to see if all my hose were hooked up and is it pretty easy to take the oil tank out and replace it?
    Last edited by K447; 06-12-2012 at 11:58 PM.


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Most likely the sender does not fit tight in the top of the tank.

  3. #3
    yeah it doesnt I thought that was normal. this is the first jetski i have ever owned so do I need to get a new sender or gorilla glue it lol

  4. #4
    Same ski, same problem. I've ordered some gasket material which I'm going to fit/attach around the sender plug to make for a tighter fit. New sender is just too expensive not to try a "home fit" 1st and even a new one will fit loose if its the tank oriface that's enlarged over time.

  5. #5
    OK cool glad to know im not the only one with the issue, let me know how it works out for you and what material you used

  6. #6
    Rasta Mon Condoms We Be Jammin!!!!! TxVirageTx's Avatar
    Join Date
    Aug 2006
    Posts
    5,775
    +1
    400
    i've put 1/4" drive hose clamps that were oversized around mine,over time i've checked them and had to re snug them,i don't have any oil leaking at all

  7. #7
    Quote Originally Posted by TxPro1200 View Post
    i've put 1/4" drive hose clamps that were oversized around mine,over time i've checked them and had to re snug them,i don't have any oil leaking at all


    Do you have any pics of that setup?

  8. #8
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    You just wrapped a clamp around the neck on the tank? That sounds like a good idea.

  9. #9

    Join Date
    Jul 2011
    Location
    mass
    Posts
    44
    I did the same as Txpro1200 on my two genesis. A hose clamp around the top neck where the sender goes and snugged it slightly and they been holding fine.

  10. #10
    My sender is awfully loose in the tank......I think I'll wrap the plug with gasket material and use the hose clamp too!

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 01 Polaris Virage TX
    By Polaris 01 in forum Polaris Open Discussion
    Replies: 10
    Last Post: 05-11-2010, 02:51 PM
  2. 01 Polaris Virage TX kill switch problem????
    By Bsharp in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 02-22-2010, 10:36 AM
  3. No Spark 01 Polaris Virage Carb
    By Amuro in forum Polaris Open Discussion
    Replies: 10
    Last Post: 10-23-2009, 03:18 PM
  4. 01 polaris Virage TX
    By wmurray in forum Polaris Skis
    Replies: 2
    Last Post: 07-23-2008, 12:23 PM
  5. 01'polaris virage service manual
    By wmurray in forum Polaris Open Discussion
    Replies: 7
    Last Post: 11-12-2007, 03:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •