Results 1 to 10 of 10
  1. #1

    Join Date
    Jun 2012
    Location
    St Marys Pa
    Posts
    23

    It runs great, for awhile

    So I bought a 2003 MSX 140 with 60 hrs and the seller tells me never had a problem.He had it out twice in last 3 years. Now I have a problem.

    I put it in the water it ran great for about 1/2 hour. Then it stalled. It started but would not throttle up without stalling. Couple hours later it started and ran great for about 10 minutes then at about 40 mph shut down. Again it would start but choked out as throttling up. Idled great. I thought perhaps plugs or fuel. Changed plugs, pumped out old fuel and took to lake the next week.

    Long story short, 21 minutes ran great at all speeds then it stalled. It starts but will not take throttle. At idle speed it made it back to the dock. It idled back to the launch area.It looks great on the water, on the trailer and in my garage. If only somebody could help me make it run all day.

    Any help out there?


  2. #2

    Join Date
    Jun 2008
    Location
    windsor ont
    Posts
    640
    +1
    8
    check the fuel pressure

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by tax man View Post
    So I bought a 2003 MSX 140 with 60 hrs and the seller tells me never had a problem.He had it out twice in last 3 years. Now I have a problem.

    I put it in the water it ran great for about 1/2 hour. Then it stalled. It started but would not throttle up without stalling. Couple hours later it started and ran great for about 10 minutes then at about 40 mph shut down. Again it would start but choked out as throttling up. Idled great. I thought perhaps plugs or fuel. Changed plugs, pumped out old fuel and took to lake the next week.

    Long story short, 21 minutes ran great at all speeds then it stalled. It starts but will not take throttle. At idle speed it made it back to the dock. It idled back to the launch area.It looks great on the water, on the trailer and in my garage. If only somebody could help me make it run all day.

    Any help out there?
    Per my signature links, you may need a replacement TPS.

  4. #4

    Join Date
    Jun 2012
    Location
    St Marys Pa
    Posts
    23
    OK, Let me be really stupid here. what is a TPS and what does it do. Tell me about this TPS gadget.

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by tax man View Post
    OK, Let me be really stupid here. what is a TPS and what does it do?

    Tell me about this TPS gadget.
    Start here;

    http://polarispwcknowledge.shorturl.com/

  6. #6

    Join Date
    Jun 2012
    Location
    St Marys Pa
    Posts
    23
    Quote Originally Posted by K447 View Post
    Thank you, Are they hard to get. Where do I find them. In my area there are no Polaris dealers or any other PWC dealers in at least a 100 miles.

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by tax man View Post
    Thank you, Are they hard to get. Where do I find them. In my area there are no Polaris dealers or any other PWC dealers in at least a 100 miles.
    I buy them online.

    This list is somewhat in need of updating but still a useful starting point.
    http://polarispwcknowledge.shorturl....-parts-sources

  8. #8

    Join Date
    Jun 2012
    Location
    St Marys Pa
    Posts
    23
    Quote Originally Posted by K447 View Post
    I buy them online.

    This list is somewhat in need of updating but still a useful starting point.
    http://polarispwcknowledge.shorturl....-parts-sources
    I found that the oil line under the oil injection tank was crimped almost to the point where the oil could not pass through it. In your opinion could this cause the machine to shut down after it heats up. I want to exhaust all the obvious before buying parts that I really dont need.

    By the way, thanks for your patience. I wish I would have paid more attention when all my friends were working on motors. I was watchinh sports and drinking beer.

  9. #9
    urugol's Avatar
    Join Date
    Nov 2009
    Location
    Sydney, Australia
    Posts
    1,231
    +1
    3
    Quote Originally Posted by tax man View Post
    I found that the oil line under the oil injection tank was crimped almost to the point where the oil could not pass through it. In your opinion could this cause the machine to shut down after it heats up. I want to exhaust all the obvious before buying parts that I really dont need.

    By the way, thanks for your patience. I wish I would have paid more attention when all my friends were working on motors. I was watchinh sports and drinking beer.
    We do that too, just gotta prioritize the time!

    I don't think lack of oil to the engine would shut it down, I could be wrong the emm (computer) seems to do a lot of cool things on these skis. You don't want that line blocked or crimped, that will ultimately lead to a major engine failure and you don't want that. Get the TPS as K447 suggests, don't buy second hand you can still get the new from partspitstop.com for 68 bucks. Part number is 2202740. The TPS is connected to your throttle body.

  10. #10

    Join Date
    Jun 2012
    Location
    St Marys Pa
    Posts
    23
    Thanks much Urugol. I am hoping the TPS that I ordered will fix this problem. I bought this ski for the kids and grandkids without much support from my wife. I look like a sucker right now.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 Virage runs great for 20 min
    By norrislakejunky in forum Polaris Open Discussion
    Replies: 50
    Last Post: 08-30-2013, 07:41 PM
  2. 2000 polaris 1200 Runs great for 2 hrs then shuts down?
    By Polaris 1200 in forum Polaris How To & FAQs
    Replies: 0
    Last Post: 08-05-2011, 08:24 AM
  3. 90 650 runs great for 20 seconds then dies out.
    By andersonn in forum Yamaha Old School Skis
    Replies: 6
    Last Post: 07-24-2011, 12:24 AM
  4. 90 650 runs great for 20 seconds then dies out.
    By andersonn in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 07-16-2011, 04:36 PM
  5. GP760 runs great for the first two minutes...
    By 1579 in forum Yamaha Old School Skis
    Replies: 0
    Last Post: 07-12-2010, 08:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •