Results 1 to 9 of 9
  1. #1

    Join Date
    Jun 2012
    Location
    Cedar Rapids IA
    Posts
    7

    Is it time for a new impeller wear ring and stater?

    Hi there I'm new to the form. And also to skis I recently picked up a
    1997 SL 780. The MFD is bad that's about it! It ran great till the hoes between the manifold and water box blew so i got a steel coupler (turns out that was a bad idea) from the parts store.
    I filled it up and when I got back to the water it would not plain very well. So I took it home and looked around to see what was posted. a few days later I took a look at the impeller wear ring and stater!
    they didn't look so good and bearing sounded bad. Is it time to get all three?


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,328
    +1
    29
    Welcome to the Hulk.

    Pic doesn't work for me.

  3. #3

    Join Date
    Jun 2012
    Location
    Cedar Rapids IA
    Posts
    7
    Hope this works
    Click image for larger version. 

Name:	jpg sl780-3.jpg 
Views:	79 
Size:	48.3 KB 
ID:	274421
    Click image for larger version. 

Name:	DSCF2412.jpg 
Views:	72 
Size:	80.4 KB 
ID:	274409
    Click image for larger version. 

Name:	jpg sl780-2.jpg 
Views:	71 
Size:	73.1 KB 
ID:	274415

  4. #4
    ripcuda's Avatar
    Join Date
    May 2010
    Location
    Newman Lake, WA
    Posts
    2,389
    +1
    166
    Welcome to Green Hulk!
    Sorry to hear about your troubles. Which hose blew? The 4inch hose between the big exhaust pipe and the waterbox (muffler looking thing)?

    So your pics tell a story. Looks like you pulled the ride plate and intake grate to get that first pic. That wasn't necessary to get the jet pump off, but you probably figured that out already. In the first picture, you have a pretty wide gap between the impeller and wear ring. That will cause low speed cavitation and lost of thrust too. So looks like you will either need a new impeller (or impeller rebuild) and/or a new wear ring which looks to be the pump base for your ski.

    The second pic shows your jet pump ate a rock and broke a nice chunk off the stator vane. Is that the only vane damaged? You can still use that stator housing with the damaged vane, but it's not ideal and will cost you some thrust as there is less vane surface to help straighten out the swirling thrust.

    The third pic shows trouble. Under your rear cone you have water damage of the bearings. Looks bad. You will need to get an impeller removal tool ($10 shipped from Overtons) and unscrew the impeller off. Then pull the stub shaft out the back and remove the 2 seals (which I bet are shot) and then carefully press/tap out the two bearing on either end. Don't lose the spacer that goes between the bearings. Then get a rebuild kit with 2 new seals and 2 new bearings and put it back together. Good trick for bearing insertion is to heat the stator housing in oven on low 150-200 for 20 mins and put the bearings in the freezer for the same time. Then the cold bearings should drop in the hot housing easily (don't forget to put spacer back in).

    Good luck!

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,575
    +1
    1,272

  6. #6

    Join Date
    Jun 2012
    Location
    Cedar Rapids IA
    Posts
    7
    Ok thanks so much for the help! This forUm has helped in more ways than you all know!

    Ya on the hose I found one on eBay.

    Any info on here about how to open and figure out what's wrong with my mfd
    It for sure has a short somewhere in it.

    The stater has a few more dings in it but that was the worst one. Great info on the bearings.
    Last edited by K447; 07-11-2012 at 06:56 PM.

  7. #7

    Join Date
    Jun 2012
    Location
    Cedar Rapids IA
    Posts
    7
    So I've been looking all over Iowa and just can't find the two seals under the impeller I checked out your post k447 and weber only had the seals through their kit and I already got the bearings in
    Any one know where to get them?

  8. #8

    Join Date
    Jun 2012
    Location
    Cedar Rapids IA
    Posts
    7
    Hey is an impeller from SBT made back to spec?

  9. #9
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,575
    +1
    1,272
    Quote Originally Posted by FATJOE4 View Post
    Hey is an impeller from SBT made back to spec?
    That would be the expectation.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP 215 cavitating, (new impeller/wear ring??)
    By nafem in forum 4-Tec Performance
    Replies: 25
    Last Post: 07-06-2015, 10:37 PM
  2. When is it time for a new starter relay?
    By yamahama93 in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 08-28-2013, 12:52 PM
  3. Help in selecting new impeller/Wear ring question
    By Fink in forum Polaris Open Discussion
    Replies: 26
    Last Post: 07-06-2013, 08:59 PM
  4. Is it time for a new engine? Kawa sts 750
    By Texwing in forum Kawasaki Open Discussion
    Replies: 6
    Last Post: 07-13-2009, 07:13 AM
  5. Is it time for an intervention?
    By ZMANN in forum Polaris Open Discussion
    Replies: 31
    Last Post: 01-23-2007, 09:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •