Results 1 to 7 of 7
  1. #1

    2000 Pro 1200 issues

    Buddy just called and is bringing me his 1200 to fix. Said his brother, I think it was him LOL, jump started it and fried the power pack. I'm assuming he means something in the electrical box.

    You guys have suggestions on where to start testing/looking or what typically gets fried from this? I'm just trying to get ahead of the game.

    Thanks, Bill


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Stator and CDI.

  3. #3
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Agreed

  4. #4
    Cdi is smoked. Do any other cdi boxes cross with the pro 1200 cdi? Having trouble locating a cdi specially for the pro 1200.

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by CrazyBill View Post
    Cdi is smoked...
    LR voltage regulator module may also need replacing.

  6. #6
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Quote Originally Posted by CrazyBill View Post
    Cdi is smoked. Do any other cdi boxes cross with the pro 1200 cdi? Having trouble locating a cdi specially for the pro 1200.
    You can use one from a 900 or 1050 if its the updated version 4010447. I am running one in my Pro 1200. They are rather hard to find and pricey though. Thats why its so important to be extra careful when connecting the battery to these things.

  7. #7
    Rasta Mon Condoms We Be Jammin!!!!! TxVirageTx's Avatar
    Join Date
    Aug 2006
    Posts
    5,777
    +1
    405
    i figure in a couple years i'll ask like 500.00 for the new one i bought to compete with marto.currently running a 92 recurved limited cdi in the tx

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 Pro 1200 random issue on shut off
    By eah026000 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 07-30-2010, 03:14 PM
  2. 2000 Polaris pro 1200 Issue no idea???
    By rdizz81 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 05-17-2010, 08:12 PM
  3. 2000 Pro 1200 Drive Shaft Issue
    By S12L00X in forum Polaris PWC Performance
    Replies: 48
    Last Post: 10-09-2009, 09:34 AM
  4. Just bought a 2000 PRO 1200
    By S12L00X in forum Polaris Open Discussion
    Replies: 16
    Last Post: 07-26-2007, 02:21 PM
  5. 2000 pro 1200 hood hinge update ??
    By SMOKEWAGON in forum Polaris Open Discussion
    Replies: 6
    Last Post: 05-22-2007, 10:08 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •