Results 1 to 4 of 4
  1. #1

    Join Date
    Sep 2011
    Location
    cincinnati, ohio
    Posts
    28

    new impeller contact

    I just installed a new solas impeller and a sbt impeller housing with wear ring on my 800 gp. My concern is there is a slight amount of contact between the impeller and the wear ring (very slight you can barely feel it drag) and I was wondering if this is normal when you install a new impeller and housing. I haven't put the pump back in the ski yet, waiting to see if this is abnormal. Also the impeller came with two nose seals, a rubber one and a metal one with o-rings any imput on which of these is best. Appreciate any input.


  2. #2
    Quote Originally Posted by riverbob View Post
    I just installed a new solas impeller and a sbt impeller housing with wear ring on my 800 gp. My concern is there is a slight amount of contact between the impeller and the wear ring (very slight you can barely feel it drag) and I was wondering if this is normal when you install a new impeller and housing. I haven't put the pump back in the ski yet, waiting to see if this is abnormal. Also the impeller came with two nose seals, a rubber one and a metal one with o-rings any imput on which of these is best. Appreciate any input.
    I have used SBT housings with replaceable wear rings on my GPR. They are primarily meant for stock Impellers as they have a bit more clearances than with the aftermarket impellers... But your new solas should "cut in" just fine... put it together, spray some lube/WD40/or even water in the wear ring housing and fire it up... or wait till your in the water, start up and ride...

    did you remember to transfer over the alignment dowels?

  3. #3

    Join Date
    Jul 2005
    Location
    Central North Carolina
    Posts
    3,847
    +1
    528
    slight prop/wear ring contact is ok if it only touches juat a tad when you turn prop shaft. Metal nose cone is the only one to use, rubber one sucks , some guys don't even run a nose cone. I run one but i put two allen set screws in it to keep it from sliding up the prop shaft. Tommy Jordan

  4. #4

    Join Date
    Sep 2011
    Location
    cincinnati, ohio
    Posts
    28
    Thanks for the info, that was what I figured but feel better with your input. I'm going to put the pump in put it in the water and ride.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need new impeller for a stock RXP
    By THEGOAT in forum 4-Tec Performance
    Replies: 13
    Last Post: 07-30-2008, 11:01 AM
  2. New Impeller & Ss Wear Ring
    By LAB69 in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 03-06-2007, 04:25 PM
  3. Repitch or new impeller?
    By 818RXP in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-01-2006, 12:25 PM
  4. Will I need a new impeller?
    By Cody Townsend in forum 4-Tec Performance
    Replies: 3
    Last Post: 01-17-2006, 02:26 PM
  5. Hey Jerry do you think i needed a new Impeller?
    By Jeff C in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 06-29-2005, 05:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •