Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1

    knock sensor, in need of ECU r12x

    Well ive been reading around... and im not even going to mess with replacing the knock sensor.. 03 r12x upgraded turbo n such... so if anyone has a compatible ECU you know what to do... $700 for new is absolutely stupid... ive seen a few post mentioning "resetting" this? there wasnt much detail but if anyone knows how, not like it will hurt it anymore.. thanks guys/girls


  2. #2
    supermac's Avatar
    Join Date
    Dec 2005
    Location
    Mooresville, NC
    Posts
    406
    +1
    10
    knock sensors are known to go bad. I suggest you start there.

  3. #3
    energysolutions's Avatar
    Join Date
    Jun 2007
    Location
    Northern Ireland
    Posts
    98
    +1
    1
    I sure hope you're right Mac, I don't know how many instances of this you have came across but could you put a percentage on how often code 25 was caused by ECM failure and how often it turns out to be the knock sensor?

    I`d be curious to hear what people are finding as everyone seems to have a different opinion, I read a thread the other day were the Tech at the dealership said he had never seen one bad ECM in 10 years of working on the skis

    The guy went on to say that based on that he just replaced the knock sensor - guess what - code 25 came back

    Looks like the tech was about to see his first bad ECM.......

  4. #4
    i got the same code, ill post back when it comes in next week, if not its the ECM lol

  5. #5
    Well with the constant fouling of the plugs, carbon fouling, and the overwhelming threads on other sites with the same issue, I havent seen one person post that changing the knock sensor was what fixed it.

  6. #6
    JRINJAX's Avatar
    Join Date
    Oct 2007
    Location
    Jax, Florida
    Posts
    872
    +1
    1
    Quote Originally Posted by majorleagueinfidel View Post
    Well with the constant fouling of the plugs, carbon fouling, and the overwhelming threads on other sites with the same issue, I havent seen one person post that changing the knock sensor was what fixed it.
    There has been one or two, but most need an ECM or a wiring harness.....

  7. #7
    energysolutions's Avatar
    Join Date
    Jun 2007
    Location
    Northern Ireland
    Posts
    98
    +1
    1
    Quote Originally Posted by majorleagueinfidel View Post
    Well with the constant fouling of the plugs, carbon fouling, and the overwhelming threads on other sites with the same issue, I havent seen one person post that changing the knock sensor was what fixed it.
    Following a code 25 fault I changed my knock sensor just last week and that cured it

    Has the ski been used in salt water?

  8. #8
    supermac's Avatar
    Join Date
    Dec 2005
    Location
    Mooresville, NC
    Posts
    406
    +1
    10
    Quote Originally Posted by energysolutions View Post
    I sure hope you're right Mac, I don't know how many instances of this you have came across but could you put a percentage on how often code 25 was caused by ECM failure and how often it turns out to be the knock sensor?

    I`d be curious to hear what people are finding as everyone seems to have a different opinion, I read a thread the other day were the Tech at the dealership said he had never seen one bad ECM in 10 years of working on the skis

    The guy went on to say that based on that he just replaced the knock sensor - guess what - code 25 came back

    Looks like the tech was about to see his first bad ECM.......

    Glad that fixed it. There is too much bad ecu paranoia going on around here.

  9. #9
    energysolutions's Avatar
    Join Date
    Jun 2007
    Location
    Northern Ireland
    Posts
    98
    +1
    1
    Quote Originally Posted by supermac View Post
    Glad that fixed it. There is too much bad ecu paranoia going on around here.
    Me too - it worked like a charm

    I knew instantly it was cured when I fired it up, the ski was idling smoothly as it had done before the fault but when the knock sensor went bad it got very "lumpy"

  10. #10
    How'd you know the knock sensor went bad other than it feeling lumpy? Mine feels like that also, but no codes or any warning lights have gone off...

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. In need of a ECM - R12X
    By h20rocket in forum Honda Open Discussion
    Replies: 0
    Last Post: 06-01-2013, 07:50 AM
  2. For my Australian customers in need of ECU tuning.
    By Green Hulk in forum Kawasaki PWC Performance (4-stroke)
    Replies: 20
    Last Post: 01-10-2012, 03:05 PM
  3. For my Australian customers in need of ECU tuning.
    By Green Hulk in forum Yamaha PWC Performance (4-stroke)
    Replies: 20
    Last Post: 01-06-2012, 04:46 AM
  4. For my Australian customers in need of ECU tuning.
    By Green Hulk in forum 4-Tec Performance
    Replies: 15
    Last Post: 12-29-2011, 11:01 AM
  5. Those Going to MUDBUG:: In Need of RXP Wear Ring.....!!!!!
    By VFX_Artist in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 06-07-2006, 07:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •