Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1

    Jetboat LS2000 won't rev up it's crazy

    Hi

    My name is Roman from Luxemburg/Europe and I need a miracle soon otherwise the LS gonna burn soon.

    After I bought the boat i realized that I could start barely start the engines but till i give trottle they died bad idle and smoke like hell ( I bought it from Ebay in Florida
    and I only saw it by picturescI trusted the seller - I was too stupid).
    The engines were the same than installed in Waverunner GP1200

    I the checked several things to figure out the problem (i have the workshop manuel)

    Compression ratio on both engines - ok
    Changed the plugs
    Checked fuellines filters - ok
    Rebuild the carbs with mikunikits
    Checked the coils
    Checked the Reedvalves
    Replaced the CDI unit (even swapped the new one from one engine to the other )
    Checked the Temp sensor - ok

    What i noticed is that the oil pumps were removed and SBT engines tab been installed .
    Please if somebody has a clue let me know

    thx

    Roman


  2. #2
    Yamaha artisan Cutlass's Avatar
    Join Date
    Oct 2010
    Location
    Madison, WI, USA
    Posts
    2,500
    +1
    55
    So the problem is that the engines are difficult to start and they die while idling? Or do they just idle rough? because these engines do shake and vibrate alot at idle. How does it run otherwise?

  3. #3
    Julian's Avatar
    Join Date
    Oct 2011
    Location
    Groningen, Groningen, Netherlands
    Posts
    164
    +1
    2
    Both engines have the same problem?

    Refresh fuel? double check your premix ratio ( you did use PREMIX? )
    Don't rush and go crazy, work step by step, it pays off

  4. #4
    Thx guys for your help

    Both engines almost same problem, one starts ok but bad idle the other i couldn't barely get started.
    When I try to give trottle the engine dies
    Premix ratio is fine.
    What did you think about srewed up crankshaft seals could this cause this sort of problem? Bad idle,smoke .
    Roman
    By the way is the GP1200R almost the same engine carbs electronic etc exept the power valve or am I wrong

  5. #5
    Hi

    Something I tried too to figure out if I have a fuel problem I tried to spray startpilot into the carbs so I have Startpilot fulltrottle ignition an compression the engine should rev up even for e few seconds
    I'am not a specialist in 2 stroke engines especially not 3cylinder ones.

    Roman

  6. #6
    Yamaha artisan Cutlass's Avatar
    Join Date
    Oct 2010
    Location
    Madison, WI, USA
    Posts
    2,500
    +1
    55
    Quote Originally Posted by Testdriver View Post
    By the way is the GP1200R almost the same engine carbs electronic etc exept the power valve or am I wrong
    No, its completely different.

    if you're worried about the crank seals, then pressure test the engines for leaks.

  7. #7
    Julian's Avatar
    Join Date
    Oct 2011
    Location
    Groningen, Groningen, Netherlands
    Posts
    164
    +1
    2
    Impellers free?

    Can try contacting SBT for info.

    Did they run bad before or after rebuild of carbs, or both?

  8. #8
    yes impellers free
    since I have the boat they run bad ,I have no history or contact to the previous owner.
    Thats why ist so hartd to find out , if at least one engine yould run so i could swap.
    I think plan B is to buy a GP1200 with good engine and swap parts step by step

    Roman

  9. #9
    Julian's Avatar
    Join Date
    Oct 2011
    Location
    Groningen, Groningen, Netherlands
    Posts
    164
    +1
    2
    You did a lot, if that's done right, you should be close.

    Fuel / carbs / airflow / reeds / pistons-cyl-compression / sparkplugs / exhaust?

    If thats all ok, try pressure testing, you can search here, and find out how to do it..

  10. #10
    Thx

    I will do pressure testing and I'm looking for a GP1200
    at least in can ride this season.Anothet Yam in my garage
    the only thing that i didnt like is the fact that I can't see this
    1200 engine anymore after all and now i gonna buy a 3 one.
    Its crazy

    Roman

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2007 Gpr won't rev up under load
    By zakre in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 08-12-2012, 04:53 PM
  2. 1999 1100 STX flooded out won't rev up
    By carms_us in forum Kawasaki Open Discussion
    Replies: 2
    Last Post: 10-20-2010, 10:56 PM
  3. 97 XP won't rev up HELP!!!
    By jared427 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 09-01-2008, 07:19 PM
  4. 97 XP won't rev up HELP!!!
    By jared427 in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 08-25-2008, 12:39 AM
  5. MSX 110 Won't rev up fully
    By bcbill in forum Polaris Open Discussion
    Replies: 4
    Last Post: 05-26-2007, 12:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •