Results 1 to 4 of 4
  1. #1

    Join Date
    Jun 2012
    Location
    Forks Twp., PA
    Posts
    4

    03 GTX DI firing on 1 cyl., maintenance light is on.

    Initially I didn't realize it was firing on one cyl., so I replaced the rectifier. I then trouble shot the ski best I could realizing the top coil was not firing so I replaced it. This did not solve the problem. I then placed the spark plug wire and coil wire from the lower coil on the upper to see if it would fire the top coil and it did. I then checked the fuse of the main relay (in the rear electrical box and it was fine). I continued to trouble shoot checking the main fuses on the brain (all the fuses were fine). I replaced the stator last season (end of season) and have only used the ski twice since installation this year and the battery is new as well (this shouldn't be any reason for the second coil not to fire). At times the ski will fire up fine and runs as it should (on and off) but for the most part the ski only fires on cyl. #1 and does not run above 4200 rpm's. At this point I'm thinking it's the main relay in the rear electrical box or the brain (hope it's not the brain because it's very expensive). Any suggestions folks, I'm at my wits end.

    Thank you!!


  2. #2
    Welcome to Greenhulk!

    I am a bit confused about your description of the coil wire; you first said the top coil would not fire, but took the coil wire from the lower one and put it on the top coil then it fired??

    The manual has specs for the coil wire resistance, did you check this? If the coil checks out OK and the coil wires check out OK, then the next place to look is the connections and wires to the rear box all the way up to the MPEM. And you need to check out the contacts for the connector at the MPEM. Best way to do this is to use a #55 drill bit and slide it into the contact to see if it grips it with resistance. Sometimes people stick a nail or probe, or a 1/16" drill bit in these contacts, which ruin them.

    Just FYI, you should check out the Candoopro system for troubleshooting. It has a feature that can fire the ignition coils so you can troubleshoot the ignition system.

  3. #3

    Join Date
    Jun 2012
    Location
    Forks Twp., PA
    Posts
    4
    Yes that is correct, I removed the spark plug wire and the feed wire from the lower coil and placed it on the upper coil (which initially did not fire). When I did this the coil fired as it should, leaving the lower coil without any wires connected. I wanted to check and see/rule out that the coil was operational.

    You mentioned contacts on the mpep, if the contacts are ruined would I have to replace the entire wiring harness or just that specific plug? Also you stated something about candoopro, is this a manual or a troubleshooting handheld device?? I'm not familiar with it. Do you know what the cost is or the best place to purchase one?

    By the way thanks for all your help, I really appreciate it.

  4. #4

    Join Date
    Jun 2012
    Location
    Forks Twp., PA
    Posts
    4
    Thanks for all the help, it turned out to be a faulty MPEM. I replaced it with a used unit at a great price and it's running like new. Had the ski up to 52 mph with no hesitation. I had it in the ocean today and it ran like new.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 130 4tec jet pump on 03 gtx di?
    By Greggpru in forum 2-Stroke Performance
    Replies: 1
    Last Post: 07-07-2016, 07:24 AM
  2. 03 gtx di hi temp reading - but engine not hot
    By nigel_miguel in forum 2-Stroke Performance
    Replies: 5
    Last Post: 07-30-2012, 09:27 PM
  3. newbie with 03 GTX di, need help and clarification
    By nigel_miguel in forum 2-Stroke Performance
    Replies: 8
    Last Post: 07-30-2012, 09:06 PM
  4. 03 gtx di - new to me keeps beeping
    By nigel_miguel in forum 2-Stroke Performance
    Replies: 4
    Last Post: 07-17-2012, 09:46 PM
  5. 2003 GTX di Stalled on water wont start
    By Big Kid in forum 2-Stroke Performance
    Replies: 5
    Last Post: 08-17-2010, 08:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •