Results 1 to 3 of 3
  1. #1

    problem with display screen

    the screen on my 05 12f shut off completly this weekend
    it has in the past slipped in to slo mode a few times but the screen went completly off now

    and it wont do anything

    im sure its fried and after getting sticker shock looking up prices for a new replacement

    were is the best place to order it and is there anything that can be done to seal it better so moisture wont kill the new one


  2. #2
    Same thing just happened to my 2004 15F. Never went to Slo Mode. Ski still runs great. Just no display.

    I'll be following to see if anyone has any suggestions.

  3. #3
    Been around for years...seen it all Kawi-Guy's Avatar
    Join Date
    Oct 2006
    Location
    Naples Florida
    Posts
    828
    +1
    27
    try the classifieds here, if none there then ebay or mitch at M&M marine to see if he has a used one

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 35
    Last Post: 04-21-2015, 07:50 PM
  2. Problem with GP760 display
    By jetmaniac in forum Yamaha Old School Skis
    Replies: 1
    Last Post: 09-17-2009, 09:14 PM
  3. Crazy Problem with RXPX display..Please Help?
    By RXTJeff in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-03-2008, 09:38 PM
  4. Problem with performance adds???????
    By terryt in forum 4-Tec Performance
    Replies: 16
    Last Post: 07-31-2005, 04:00 PM
  5. Found my Problem with My RXP after Service.
    By Water4fire in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-20-2005, 03:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •